Hearthlings not gatherting remote items

Title: Hearthlings not collecting everything they are gathering

Summary: items are not picked up from the ground

Steps to reproduce:

  1. make a large storage area to hold everything
  2. go chop wood about 20 large blocks (4X4) away from your flag and stockpile
  3. wait for them to collect it

Expected Results: that they would start picking up all the stuff you ordered to collect via the harvest tool the loot collect button has the same problem

Actual Results: everything is left on the ground

Notes: they do start collecting if i place a collection zone much closer to the stuff that is on the ground


Version Number and Mods in use: latest steam version no mods

System Information:

Hey ! Try to pause the game for a few seconds : pausing the game should resolve the idling problem :slightly_smiling:

I will try that tonight sure hope it helps cause redrawing the same mining instructions each time is a pain in the b*tt

Think the only thing I’ve ever run into is long distance hauling. It takes them even longer to get the idea to haul something near the edge of the map when town is at center. Doesn’t help that my civilization has only a ladder up to a plateau.

However they do pick the items up, it just takes more time since they are more onto the stuff that is closer. I literally had to stop things for a day or two before they decided to pick up Loot that far away. Mainly it is Loot that has long path to.

Yes they idle for quite a bit, even at the campfire. This took a day or two before they went out. In game days. On the otherside of things I think I’m a bit too patient to actually wait for that to happen. I really wanted them to pick it up. Now just awaiting them to chop a cactus that is long distance.

Reason is that the goblin camp that spawned had their piece of wood spawn on top of the cactus. >< That might be a bug in itself… Don’t think the wood that spawns with goblin camps is suppose to be spawning in an unreachable place like that. Well without to build or harvest something first.

Overall it is minor, and I haven’t noticed them not eventually pick up things; even if it takes a couple in game days to decide on it. :slight_smile:

When you start having a lot of HL, it starts to bother you :grin:
The pause should resolve the problem for a moment.

Doesn’t really seem to work that way as well… Then again I have been doing that and they still take just as long. Of course my system is roughly the minimum anyway, and trying to figure on what my max hearthling limit my computer can handle.

Beyond the obvious long time playing bug I was able to handle 18 and probably can handle 20; however I stop at the prior number just so I can build my town more. :slight_smile:

So it might be because I paused often, that they do end up eventually picking things up; even if it takes them a moment longer than an acceptable building… thanks anyway. I’m patient enough, as I always take my time with these sort of games. :smiley:

That’s strange… When they’re idling, I pause like 5-6 seconds while checking their tasks and all their tasks are changed into something else than idling, and I have 22 HL though.
If pausing doesn’t change anything, we’ll have to wait for the Alpha.

indeed. I have no problems when things are close by, and that actually works.

It is when things like loot and tasks that are far away by hearthling pathing that they don’t immidiately respond. It does take days in those cases. So here’s to improvements eventually. :slight_smile:

Note: I have about 18 hearthlings, so pretty close in number to yours. 2 are soldiers.

well I tried the pause button and it worked
But I need to wait till the color bar below right stops moving

Yes, each color has a different meaning. The yellow colors are pathfind, which means the game is figuring out paths for your people (so they can reach an item, inventory, enemy, or flee, etc…Their brain is working into something), green is idle, which means the game engine is simple done with all the work and is doing nothing. At this point (when the bar is mostly green) they already figured it all, and you can release the pause button.