Hearthlings don't place Workshops

Well i just updated to the latest build on steam, version 15 Dev or so,
and i started a new village. But it happens that when i craft a workshop item like the loom and then try to place it, the item disappears from my inventory but the item wont get placed. As soon as i restart my game the hearthlings place the items immediatley. That happens for every workshop items.
Since i just started with the new version i also started a new village and have 10 hearthlings only and also i don’t use and mods, but i do use the 3rd speed.

Have you try’d it with another new game to see if it happens again? Have you try’ed it with out the 3rd speed?

Additionally, are you playing Rayya’s children? You mentioned the loom, and there is a known issue with A15 weavers on RC only…

I ran into a similar issue yesterday. Playing the ascendancy, I could place the carpenter’s, Weaver’s and Mason’s equipment just fine, but the herbalist took a really long time, as in several days to place down his workbench. Meanwhile I tried moving it somewhere else, which just generated a lot of different “ghost” versions of it. I crafted a second and a third one. I eventually sold over of those and then the other one was placed. The ghost ones remain iirc.

Alpha 15 preview as well, and a new game, for the record

No im playing the other race in the forrest.
Also it happens with almost every workshop item.
It happened with the cooks pots and the smiths forge and the carpenters bench.

I just tryed a new game, still same bug. I have played with 3rd speed and also one safe completly without the 3rd speed option, still same bug.

Ran into this problem too. Happened with my blacksmith anvil, 2 of my weaver’s stations and all of the cook stations. I tried making a second workshop and then it got placed, and sold the extra one when the next merchant came by.