Hearthlings can't build multi-story houses with stairs directly

First time posting here on the Forums :smile:

Still not possible to do two story houses with stairs added directly the hearthlings don’t want to to start building those houses.

How to make this kind of House
Create a Floor anything just simple
Put Walls on the floor
Add a door
Create a Stair to second floor but leave last block to not screw up second floors walls
Creates second floor same size as floor below
Add a roof
Now remove parts of second floor to let the stair from first floor to reach second floor.
Add last part of stair so first and second floor is connected

Try build nothing happens.

Temp Fix
Would love this to get fixed.
Temporary solutions is to make so you cant go between these floors and remove floor once house is done and should work then.

i had same issue - i have screen shots attached

while picture shows two story house is not paused but workers are idle

so the roads was working so its shows as showstopper bug which needs fixed

My suggestion change the tag for BUGS not suggestions

1 Like

Changed to BUGS did not know i could scroll thanks! :smile:

Done a few more tests just to help provide more information for potential bug helping.
I made a house 7x7 with stairs they did not want to build this Not Working
I made a house 7x7 without stairs but made a hole to prepare for future stairs adding worked
I made a house 7x7 with slab on bottom floor 3x3x2 worked
I made a house 7x7 with slabs added to the side without reacching second floor just touching the side of the walls this made hearthlings not building it Not Working
I made a House 10x10 this time i made sure that the stairs made in slab did not touch second floors floor and no walls and they build this Working

So the issues to me seems to be that if the slab from first floor touches seconds floors floor or any wall they will not start building this

10x10 house they started building however they did not finish this house

Just wanted to make sure that any dev have read this so we might have a fix in the future for this Big Issue.

Tried this in Alpha 13 with same results

Hey there @Banto, thanks for the bump! I can tell you that the devs are well aware that there are building issues, this one and others, and do want to fix it. Unfortunately, many of the issues with building are going to take a bit longer to fix from an AI perspective than we (and they) would like, but they are being worked on. I don’t have a timeline, but I can say that @not_owen_wilson is working on a major overhaul of the building system, but to emphasize again, no ETA.

1 Like

Thank you.
Just good to know that they are aware of it for future fixes :smile:

1 Like

This should be resolved in A15.


tested and confirmed working :slight_smile: only thing that i seen bugged with this atm is that they leave scaffolding left in the “Stairs” for example here is a screenshot

Alpha 15 Develop 2860