Hearthling "Vanished" on roof during construction - still Active / Idle

Title: Hearthling “Vanished” on roof during construction - still Active / Idle

Summary: While completing the shared housing building, my active farmer somehow vanished but was still active in idle status. The only thing left of him was his gardening hoe. I changed him back to a worker hoping that would fix or reset him but it didn’t help. The other workers had completed the roof and taken down scaffolding but he was still up there and I could target him and get the camera to zoom on him but there was nothing there, just the hoe :frowning:

Steps to reproduce:

  1. Build Shared Housing Building
  2. I don’t know - random workers all on roof?
  3. Check Hearthling status page and find idle hearthling not doing their job when work available… stuck on roof/invis.

Expected Results: I don’t know that this can be reproduced really.

Actual Results:

Notes: I tried to save and exit game to see if a reload might help the problem but the game froze on trying to save and I had to use task manager to kill it and the game unfortunately did not save either.

Attachments: I did get a screenshot showing the hoe on the rooftop where “Zedd” (my farmer) should be but I haven’t uploaded it and I doubt you need to see that.

Versions and Mods: Stonehearth 0.1.0 (develop 2283) x64 build / No Mods used.

System Information: Windows 7 Pro - 64bit / Intel i7 CPU / 6 GB RAM / NVIDIA GeForce GTX 650 Ti Boost

Update: Started another game but am completely unable to save at all - game freezes when save game selected so that first freeze/crash may not have been related to the vanished / invis hearthling on the roof.

I don’t think I’m able to play the untested A9, is there a way to revert back to A8 without losing a previous A8 save or do I need to wipe the whole thing and re-download A8?

Edit: I downloaded the A9 version from Steam. Not sure if that matters or not.

This happens sometimes when workers take down scaffolding too quick and someone gets trapped. If you have the cut-away view enabled, the roof is visible but everything on it is hidden. This us a known bug and will be fixed at some point. To see them, undo cut away view, and to save them, build a ladder up ro the roof.

This hearthling was definitely not just stuck on the roof with the cut-away thing on. I have a screenshot where the roof is completely up and you can’t see him nor can you interact with him. I suppose I could have tried putting a ladder up to enable the invisible hearthling to climb down and maybe it would have fixed it but that was the point I logged off to try and see if a reload would fix it and the game then froze and the save failed so I no longer have that game to try it. :frowning:

I’m also unable to save any new game in Alpha 9 version. I want to revert back to Alpha 8 but not sure how to do that except deleting the game and re-downloading it.

Whats the Dev build on the one you updated too? The save game is a issue here and there. But try a restart, see if that works.

I downloaded the (develop 2283) x64 build from Steam from the post you replied to someone about how to get newer versions on Steam I believe. I was actually looking for information on what to do with all the goblin tokens and you suggested the new build because they removed / lessened them?

Well normally I have little fear of trying untested beta builds but this one’s really throwing my game for a loop as I cannot save at all - even new restarts. I’ve tried three new games now …new world, new everything and it freezes immediately on saving.

Still no mods, nothing. Did you try a full deletion and reinstall ( meaning you need to go to steam folder and completely remove it). The saves shouldn’t be a problem fully. It is bugged still, but not that bad. They use to be. Try flipping to x32 bit too… (it’s in your options. ) last option is go back ot steam, find your game, right click, click properties, last tab, select opt out, that will put you back in alpha 8 stable build.

1 Like

Ok I’ll try those suggestions this evening after work and see if any of that helps with the save issue which is entirely separate from whatever glitched out that hearthling on the roof.

Another reason I know it wasn’t just a case of being stuck and the walls-down view was because I remember how odd it was that the hoe was just hanging there in mid-air on the roof where the hearthling was supposed to be. It was definitely bugged out. Can’t reproduce it and that game is gone since it crashed on save/exit.

That’s a very rare and I mean rare bug. It does happen, and you cant get them back. Just have to start anew

Yes, that’s what happens. The cutaway is still active, the roof is wholely visible but the hearthling isn’t. It wont look like the cutaway is turned on, because if you save the game with cutaway on and then reload, the cutaway will still be active but the cutaway ICON will show it as being turned off.

To correct that, you have to press the button twice, the first press changes the button and turns cutaway “on” (even thought it was already on) and the second press actually turns it off. This has been the case for ages now, and will presumably be fixed at some point.

Ah this explains a lot! It doesn’t explain how the hoe was just sitting there in mid air though - is that part of the bug or glitching? So if I had built a ladder to the roof, the invisible hearthling (or visible had I done the cutaway thing right) would have climbed down and been fine?

Sadly, the fact the game froze and crashed and is gone just makes it more frustrating but hey I signed up to play the minimally tested version so I have to live with that. I’ll be trying to reload / reinstall later this evening as suggested by @micheal_handy76_mh to see if that corrects the game freezing on save issue I’m having.

Correct. I have had to do that a few times now and then, when someone has been on the other side of a roof when other Hearthlings decided to start taking down the scaffolding.

Uploaded the screenshot I said I had to show you that I did in fact have the roof all the way up and this was not a case of a stuck hearthling because you can see the hoe just sitting there. Hearthlings don’t drop their tools when they are stuck on a roof that I know of, right? He’s invisible, that’s his location but he’s not there and I then tried to save and exit and lost this entire game so I can’t go back and mess around to try and fix him. :frowning:

I don’t know what caused this glitch - it’s in the unstable A9 version currently out so yeah, could be anything and I am testing that version knowing fully this stuff is possible. I’ve also got traders dropping goods in mid-air above my firepit and goblins spawning in piles in mid-air above their own fire pit so there’s issues. :smile:

1 Like

Yeah, he is gone from game, why the hoe is sparkling on roof. just that game is confused and thinks he still there. Rare bug, no way to get him back

1 Like

I also noticed something while i was building a custom house. if the hearthlings go right from building the walls to the roof, they may forget the gap between the wall and the roof, and a hearthling may get stuck up there. the hearthlings may also get stuck up on the roof when the scaffold is gone and the game does not know they are there and wont show them.

1 Like

This happened to me just now and I found a way to reproduce it:

Build a house, when the hearthlings are ontop of the roof-contruction “slice” the view and they disappear.
(They = them building up the roof, when they (while invisible) move down the ladders, they become visible again, but move them back on top hides them.)

Finally fixed in Alpha 19. Hearthlings (as well as other non-building objects) will be visible if they are standing on a visible structure, even if the slice mode cutoff is below them.

1 Like

@Albert, just want to confirm is this fix going to be in the next A19 latest release, or not until A20? The tag you added #fixed_for_next_alpha is used for fixes that won’t be added until the next alpha. We use the tab #fixed_for_next_build for fixes that will be in the next latest release.

@jomaxro Fixed in the current unstable build (develop-3169). Feel free to change the flag to what’s most appropriate.

1 Like

Got it, so it’s resolved! Awesome :confetti_ball: