Hearthling stuck in an open area

Hey, short time browser, first time poster so I hope I’m putting this in the right place.
I have a hearthling that I had promoted to a Shepard from Trapper. Which was cool until they got stuck in an open area chasing a non existent pig? See screenshot.

I’ve tried resetting them, demoting them and setting the town to defensive in the hopes they would move. I’ve tried putting a ladder near them. As you can see another hearthling came and collected the shepards hook after demotion so I’m not sure what do?

They are very emotional and will probably start crying soon…

1 Like

More info:

Mods used:
Cookmod (I guess the pig came from this)

(I didn’t realise there was so many active D: )


select the that Hearthling then open up your console. (CTRL + C)

Type reset into the input box then hit enter.
this will reset the Hearthling’s position.

close the console by doing CTRL + C again. :smile_cat:

I tried doing that but the little hearthling just pings about and still stays standing there. I waited after each reset and even though they were hungry they didn’t go for food.

hey there @CharoumSkye, welcome to the discourse :smile:

could you provide your save file? To upload a save,

locate the folder in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

also, as this might be caused by them trying to chase an animal from a mod, i’m going to page @Froggy to see if he knows of any problems like this with his mod.

I hope that works, this is the first time I’ve used that thing…

Thank you. :smile:

Thank you for you help. After feeling paranoid that I’m just being an idiot, I’ve loaded the game again and they’ve moved!! Even though I had already tried that…
They just wanted to make me look bad. :unamused:

Edit: I will promote them again after they’ve eaten and watch them to see if they get stuck again.

Well the pig has been located this time but she’s still stood there doing nothing? Could it be a clash with another mod?

(Realised I like triple posted so condensed them all into one)

Maybe the pig is moving, so when the shepherd reach it, it is not there anymore, and the A.I. fails.

Other animals actually stop moving when the shepherd tries to reach them. (from what I remember)

When I click on the marked out part where the pigs are suppose to be taken to it says 1/5 so I think they think it’s been tamed?
The pig is still wondering around while the shepherd is stuck.