Hearthling glitch/stagger randomly

In some precise position, Hearthlings are stuck and begin to glitch on spot for no apparent reason
Steps to reproduce:

  1. Try to build a settlement on a desert small hill
  2. Wait and see

Expected Results:
Hearthlings doing their business normaly
Actual Results:
Hearthlings doing their business and some time glitch on spot, making them unavailable for work.
Seen only with RC in desert biome when i tried to build a village on a small hill, save file attached
Tested in two different save, this save file is supposed to produce the bug after a few seconds.

bug start

bug continue (and the mason just joined the fun !)

settlement global view

save file:
1453239265131.zip (5.9 MB)
Version Number and Mods in use:
Alpha 14 - develop-2797 (x64) - No mod
System Information:
Geforce GTX 850M
intel i5-4210H 2.9GHz
Windows 7 Pro

I have not seen this with all hearthlings, just my footmen so far (also in the desert biome). Here is a save to support what I saw.

Steps to reproduce:
On loading the footmen are outside of my walled area in the current glitch spot. (they just did combat and got stuck returning). If for some reason the save doesn’t spawn enemies within 30 seconds for them to attack, select Party 1 and issue an “attack and move” command to the goblin firepit. This should cause them to kill it and then glitch out again.

Also another few minutes after this happen game performance seems to really tank.


0.14.0 (develop 2797) x64

Paging @Ponder, could this be related/similar to the stuck footman you worked on this morning? Looks like some saves might be of use above.

Does this behavior remain after loading the game? I have experienced the same problem regularly in my latest game (through the first 2 builds of pre-Aplha 14, though), but saving and reloading instantly solved the problem again.

I think this is the same behavior I called “ring-around-the-rosy” with footmen in the past unstable build. I didn’t notice it so much in 2797 but then it seemed like Farmers and refusing to harvest was the bigger issue at hand in that one.

I will add this, it only seems to happen to me in the Rayya’s Children / Desert Biome. I never see the Ascendancy in Forest doing this odd circling in one spot glitch.