Haulable Entities Get Stuck Inside Ladders

Summary:
If Hearthlings elect to empty their backpacks while traveling up or down a ladder, the entities that they were hauling can get stuck inside ladders,. (Re-)moving the ladder will free them. Reloading isn’t a reliable method, as I’ve seen them persist.

Steps to reproduce:
1) Build a ladder and place it logically into the world.
2) Create AI paths that require hearthlings to place/use them.
3) In the case of mine ladders, you’ll occasionally see blocks of various resource types like coal, stone etc get stuck approximately 1/3rd of the way down the ladder, from the top.

Expected Results:
If there is no room left for them to haul their lunch, they should first empty their backpack at their destination (finish their active task) before stopping to eat.

Actual Results:
Hearthlings empty their backpacks when traversing a ladder, or at illogical times, such as at lunch time, when this issue tends to happen more frequently.

Notes:
I know this one has been reported a bunch of times, in various forms, in the past, but since some of them date back a year or more, it seems important to note that it’s still a thing.

Attachments:
Save game: here

Recent screenshots will be added here shortly.

Versions and Mods:
Will be updated once I find the screenshots. :slight_smile:

System Information:
Win 10, x64, very new hardware (can provide a full profile upon request)

4 Likes

Stuck in fence

Summary:
My cook got stuck in my fence probably when it was built. I noticed that when an hungry icon appeared above her head. I could unstuck her by removing some of the fences.

Steps to reproduce:
I haven’t tried to reproduce the bug

Attachments:

Versions and Mods:
develop-2699 (x64)
no mods

System Information:
Win 7 64 bits, 16Gb

1 Like

@Albert, isn’t this the bug you just crushed?

Looks like Xandoria experienced this in dev-2699 as well.

Yes, I did fix this, but it looks like there’s another bug causing them to get stuck.

2 Likes

Thought I would add to this that it was my cook in specific that got stuck actually. I have tried to delete all the fences around him to no avail. Cook at lvl 2 and stone fencing.

Hey there @icewinds, welcome to the discourse! Thanks for the very specific details, always helpful for the devs.

This should be fixed as of develop-2720.

Unfortunately, I ran into it again on Alpha 13 dev-2720 this evening. A Shift-F5 cleared it up.

You can see it happening at 2:31:15: Video

Savegame: Here

Full Episode Notes:

  • 07:13 New settlement spawn allows for stranding of hearthlings on the tops of cliffs, etc.
  • 23:00 Did that hearthling just pull wood out of the mountain as a mining drop?
  • 25:00 AI Suggestion: Consider ways to solve over-crowding in mines besides just reducing the # of miners.
  • 50:00 Trying to rotate an item that has already been placed, but keep it in the same location, creates a ghost that is one block off. The item still gets placed correctly however.
  • 1:06:30 Promotion UI bug caused by having the job selection window open when the available jobs change.
  • 1:15:30 Model Suggestion: Consider making it easier to tell which way clay seats are facing.
  • 1:18:00 Idle Hearthling bug persists? Had ladder removed out from under her, but she’s still confused. Shift-F5 fixes her.
  • 1:20:00 Scaffolding cannot be cleaned up due to how the building was placed on the exact corner of a cliff.
  • 1:21:30 AI Suggestion: Consider only triggering combat music when a hostile mob has successfully pathed to a hearthling.
  • 1:40:30 New hearthlings spawn very far away from the base. Seems to be based on the uncovered map area?
  • 1:44:00 Premade Structure templates do not allow Slope/Direction/Size changes, but the UI is present (does nothing)
  • 2:14:30 Remove building command throws Engine Error, possibly because two sides are inaccessible due to cliff?
  • 2:31:15 Hearthlings glich out on ladders during building deconstruction. Shift-F5 fixes them.
  • 2:41:00 Hearthlings are not deconstructing buildings. Order was given at 2:14:30 (above), and still no deconstruction.
  • 2:48:00 Trapper Suggestion: Especially RC, where food is scarce, consider prompting the player to ask if they want to adopt an animal or not.
  • 2:54:30 Loom only requires two blocks of open space to place, but it overhangs by 1. When placed near a stockpile, this can cause storage items to be placed on top of the loom.

NOOOOOOO!!! It’s back! (or maybe it never left :scream:). Anyway, paging @Albert!

1 Like

@jomaxro Please note, backpack items still get stuck in ladders today. It seems to happen most around lunch time when hauling from far away distances. The good news is that though they do appear to float in ladders, at least these days they do get retrieved (though that usually takes quite a while, whenever it happens).

It’s not easy to replicate, as it seems to happen randomly, and occasionally at that. I have recent screenshots though, if proof is necessary.

Does that warrant reopening this, or is that a different bug reported elsewhere?

1 Like

Sure does! Mind updating your original post with the current info? Will move post back to #support:bug-reports

2 Likes

Question, just so I do it right: Do you want me to edit the original post with what I just posted as a comment?

1 Like

I would edit the original post as if you were reporting this bug now…anything that is no longer applicable can be removed. If you want to keep it visible for reference, then add the new details above the original post.

2 Likes

A post was merged into an existing topic: Resources not removed from building roofs before ladders are removed

I think a more general “Hearthlings empty their backpacks at illogical moments” bug report might be warranted. This one is specific to entities getting stuck on ladders WHEN a hearthling empties their backpack at one specific illogical moment; traversing a ladder.

2 Likes

…and according to the A15 changelog this has been resolved (again).

Looks like! I’ll keep an eye out for it. :slightly_smiling:

2 Likes