Guard Refuses to Move after Defending

After sending a level 6 guard to defend the entrance to a mine up in the mountains, she will not move, even after cancelling the defend order or ordering her to move/attack elsewhere.

Version Number and Mods in use:
Ver: release-519 (x64)
No mods in use.

System Information:

that is how the defend order works. They sit still in that location as if guarding the queen’s territory.

However they should stop doing so with new orders.

Also there is 2 ways to go about it.

One is through the group thingy for military, and the other is on the individual hearthlings. Now if you did that defend thing on the hearthling, and later proceeded to do a cancel through military… They will continue to defend because Hearthling/individual military commands take priority over the group military commands.

Which means you would have to select the hearthling itself and issue the cancel or different command.

If you set defend on the group military, and later issued an order on the individual hearthling, they will do the order and then go back to defend. Which means you would have to cancel or change with the group selected and not the individual.

If set on both you will have to remove it on both.

Even after all that if still does not work, then yes the part about them not listening to orders of the cancelling or new orders is a bug, since they are suppose to act on that. Best to reload game in those instances to see if that helps or sometimes pausing the game and wait till the bar in the lower right corner turns mostly green, and see if helps.

Either way they should be doing something… hmm…

This is precisely the problem. I ensured that all orders were cancelled individually and in party mode, tried moving her in both, tried swapping her party and re-ordering/cancelling, nothing. She began starving to death and still would not move, eat, or sleep.

I ended up swapping her job back to worker and that seemed to un-stick her. Then I was able to swap her back after she slept.

1 Like

i could get it to move, by spaming the “r” button. but i can’t get it to eat. or put on armor without makeing it a worker, then a footman again

Just making sure. That would most likely be a bug then. As that should not happen.

Well a least you found a work around for the time being. makes me wonder what the cause is though, as I personally not ran into this. maybe someone else has a clue, as I am merely another player. :slight_smile:

After all that specific command is pretty much the same as the command that was in A13.

shift f5 is your friend I find. I tried reloading the UI but I couldn’t get my guy to move until I reloaded the game.

this problem maybe was solved, but it is back.

my 1st footman wil not eat, so i made her a worker, she didnt do anything, made her a cother, changed didnt eat, made her back to a footman, thnk you for the delevel with no outcome. she is about to die she won’t eat.

Did you try reloading the save? (After chaging the job to something els)

It might be able to reset the calorie tracker and make her eat once more!

hey there @MaddLagger and @Liambic, welcome to the discourse :smile:

@MaddLagger, i just merged your thread to over here, as from what i could tell you’re issue was caused by this one.