Footmen not taking orders

When trying to give footmen or any other member of my combat party orders, they do not act on them unless the objective is within short distance of where they are, no matter what the command. i have tried to disband the group and place the members back inside however this also does not work

running latest version (steam latest build)

Is there a path available for them to reach the further targets? Are you running into performance issues in general (perhaps you have a lot of hearthlings and a lot of items on the ground)? Do the members of the party have their Job activity enabled (checked in the Citizens view)?

Have you tried pausing or slowing down the game? I’m on a 4GHz machine and sometimes hearthlings don’t do what they’re supposed to unless I slow things down due to performance issues.

i havent checked their job activity but they do patrol constantly which leads me to thinking they are active, ive tried pausing and slowing down the game, it wasnt sped up to begin with, i have also noticed that they only dont follow my commands when they are inside my village, if they are a large distance away they follow no problem

Is the problem then that they can’t path to where you placed the command flag? :thinking:
Is there a way for them to enter / exit your village (a door, a ladder, etc)?

there are no walls, and even where im telling them to go is within my village half of the time, would there be any issues if this were a multiplayer save?

If your combat units are set to work for the other town, I think they still would follow your commands, but would patrol only the other player’s storages. If they’re working for you it should work as expected :thinking:

If you upload the savefile we can take a look at it. Maybe there’s a bug.

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

ahh just checked today and it seems they fixed themselves, must have just required a restart, sorry for the hassle