Footmen rush to camps automatically

Summary: soldiers keep running at enemys and not healing

Steps to reproduce:

  1. when the first goblin boss shows up
  2. let your guys attack the invaders
  3. pull them back and watch

Expected Results: the footman will continue to run back at the goblin no mattter how far away you are and wont heal at all while in town, and the healer doesnt heal the soldiers

Actual Results:

Notes:

Attachments:

Version Number and Mods in use: alpha 16 no mods

System Information:

This has been an issue for awhile. The Developers are aware of this issue and many suggestion have already been posted of the forum of what player would like to see. Much in the way of a break contact flag or command or being able to set a health limit. Combat mechanic are continually being tweaked each alpha and hopefully this will be address soon as they are moving toward alpha 17 now.

Summary:
My footsmans attacks enemy camps automatical. This bring themself in danger, because they are somekind of bloodthirsty.

Steps to reproduce:

  1. load savegame, try to keep the crypt alive. -> hearthling “Sean Nonac” will always run into fight. with the crypt.

Expected Results:
As a player i want the control about the attack time of enemy struckture. I want “No-Go-Areas” for my hearthlings to keep them away from dangerous situations.

Actual Results:
In the currently savegame all other zombies are dead. but his teammate run into dead. I wasn’t able to stop the fight. I tryed it with the movement order but they always run again to the crpyt. Dosn’t take care for health or wait for healing from hearbalist.

The attacking hearthlings can’t protect my village, so i lose units while they are somewere fighting.

Notes:
The savegame has also a script error, it looks like it is not related with the reported issue

develop-2867 (x64)@stonehearth/components/ai/ai_component.lua:562: (5060332 Bleck Cordless) has not yielded after 10 ai spins. Are they in a bad state?stack traceback:
radiant/modules/common.lua:223: in function ‘report_traceback’
radiant/modules/common.lua:442: in function ‘verify’
stonehearth/components/ai/ai_component.lua:562: in function <stonehearth/components/ai/ai_component.lua:522>
[C]: in function ‘xpcall’
radiant/modules/common.lua:243: in function ‘xpcall’
stonehearth/components/ai/ai_component.lua:522: in function ‘_thread_main’
stonehearth/services/server/threads/thread.lua:249: in function <stonehearth/services/server/threads/thread.lua:246>
[C]: in function ‘xpcall’
radiant/modules/common.lua:243: in function ‘xpcall’
stonehearth/services/server/threads/thread.lua:246: in function ‘f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

Attachments:
footman_rampage.zip (9.0 MB)

Version Number and Mods in use:
develop-2867 (x64)

It looks like the renaming completly missdirected my bug.
Not sure if the attached callstack is connected with my problem.
The problem is about bad footman control

1 Like

Summary:

Some soldiers are attacking far away enemies by themselves.

Steps to reproduce:

  1. Load the linked save
  2. Remove the guard order from the archer

Expected Results:

Either:

  • The archer resumes hauling goods or patrolling around the placed farms; or
  • His whole party attacks the camp together.

Actual Results:

The archer immediately starts chasing by himself any of the enemies that are located on the nearby goblin wolf camp.

Notes:

It’s not only this particular archer, but there’s always one of my soldiers that will attack an enemy camp alone, and they most likely die. Just before this, I had promoted a worker to Footman and just after he got his wooden sword, he went straight to the enemy camp.

And this also happened on previous versions of the game.

See also similar reports:
http://discourse.stonehearth.net/t/footman-attack-enemy-camps-automatically/20504
http://discourse.stonehearth.net/t/bug-with-the-soldiers/22449

Attachments:

Savegame

Version Number and Mods in use:

Alpha 17 develop 2008

System Information:

Intel i5-3570 @ 3.40 GHz
8 GB RAM
NVidia GeForce GTX 560
Windows 10

I’m seeing the same problem (Alpha 17 develop 3010 x64).

As a temporary work-around; go into the “Citizens” menu (the list of all your people), find your footmen, then unselect their “job” checkbox. This will prevent them from rushing half way across the map to die - they will eat, sleep (and get healed), and haul instead; and will still attack targets if you manually command them to (but they won’t patrol).

Fun fact: Later in game (when I’ve got 20+ military trained to max. and there’s not much point patrolling because there’s only one entrance to the fortress) I set most of my military like this just to cope with hauling. It just means you need to do a little more micro-managing during attacks, as once one enemy dies they’ll walk straight past other enemies to collect wool or something. :relaxed:

Ran into this again in a new save. Do you guys need more samples or is it enough saves for now?