Footmen revert to worker tasks

After some point all my footmen stop patrolling and just default to worker jobs like moving items around, they don’t even react when town alert is activated.

Hey there @hillc576, can you provide a few more details about your game when this happens.

  1. What version of Stonehearth are you running and do you have any mods enabled?
  2. Approximately how long were you playing when this happened (in real time)? Are we talking 20 minutes, or 20 hours?
  3. How many Hearthlings did you have when your footman stopped patrolling?
  4. Did you receive any engine errors while this was happening?
  5. Can you upload this save game to the discourse?
1 Like

ya sure

  • 16 Hearthlings
  • Release 472
  • Ya I’ve had alot of engine failures
  • Maybe 4 or 5 hours of real world time?
    I’m not sure how long the save has run for, its really my test world for new features that come out until I’m happy with the state of the game for a long haul game session :3

Here you go
Dropbox - Stonehearth save

In order to upload a save, upload the save folder from your computer (in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games by default if installed via Steam) to a cloud storage site like Dropbox or Google Drive, and then copy the sharing link here.

I updated the reply with everything you asked for. Need anything else?

That should be enough for the devs. Going to page @sdee and @albert to come take a look tomorrow…

Alright cool thanks for taking a look

1 Like

Any updates on this find?

I have an update on the footman issue. I started a new game to see if the latest patch fixed the issue, if I started fresh. However I ran into the same issue again, I think it happened when i put the two footmen into a group and told them to attack an aria.

Maybe when they are told to relax they relax too much?

1 Like

My footmen still seem to do this sometimes too. I find that ordering them to attack an area will sort of “reboot” them and they go back to patrolling etc. Not sure if this is a common bug or just a freak incident.

ive had to have only ‘job’ checked. it seems having the haul or any other option on a footmen checked has a habbit of causing this.

haven’t had this happen in aobut a full game month once I unchecked my footmen’s haul, build and mine boxes

In that case, this might be a known issue. From the A13dev2697 changelog:

Also, in this iteration of HT, some specialized hearthlings are able to perform tasks which previously were not available to them (e.g. farmers can be instructed to mine). Both of these issues will be addressed in subsequent releases.

Going to ask for a confirmation on this from @brad: was this thread the idea of the “known issue”?

1 Like

Tried to see if there is a recent post on this issue but could not find one. I am playing using the latest build after a lengthy absence from the game. Love how the game is coming along but… Again I have the issue of my military (all four classes) reverting to hauling instead of patrolling. I did not change their duty settings via the job management screen. The only actions I took were changing my stockpile location and size to make way for a building and opening the Loot command to group loot a large number of items. This happened in the game month of Dewmun. Exact details are vague as no error message occurred and I am sure I have seen this issue around the multi-loot command before.