Graphic Bug - Black Area in Game


All the sudden I got a black square in my game. It just displays a black area. Even if I scroll around and zoom in and out. See the screenshot.

Attached the Graphics settings and a screenshot of the Graphic Bug


Version Number and Mods in use:
A16 2940
No mods

System Information:
i7 3720QM

Edit: I just appears to be at daytime… during night it seems to be okay

1 Like

Welcome to the forum, @emzet :smiley:

I’ll page @not_owen_wilson for you, this seems to be a problem with the renderer, although it could be something else…

1 Like


Does this happen even after quitting and reloading the game? If so, can you post your save to this thread? Your save games can be found here:
For a Steam install, open C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games .
For a Humble install, open C:\Program Files (x86)\Stonehearth\saved_games .

You can tell which save is which by looking at the screen-shot. Make sure to zip up your save!

There are some instructions here on how to post your save.



I have this problem too with a gpu Intel HD graphics 5500 i can reproduce it.
Like this :
1 - remove …\user_settings.json
2 - start stonehearth
3 - load a save game
4 - wait till all is active in view + don’t move the camera (UI,etc…)
5 - put settings like shadow detail to off, maximum number of ligths to 1 and Maximum number of Shadows to 0
6 - turn the camera where at 180 and some part are black not all the same each time

To correct this for the moment save the game, close the game and restart and reload the save game.
I will try this with my old computer with a nvidia GT 610 card tomorrow and report if necessary.But i don’t right now it’s 3am here :wink:

Edit : This bug happen in night too with a Intel HD 5500 (Windows 10 Pro 64 bits Intel Drivers from august last years i can’t put last drivers cause lenovo are bad guys ^-^).I can reproduce this bug too with a Nvidia GT610 (Windows 10 Pro 64bits with Nvidia Drivers Version 361.75). With more details now i put options like this before the bug and play the game and change options like i said before this edit :

  • Shadow Detail : just a touch
  • Maximum Number of lights : 50
  • Maximum Number of Shadows : 3
  • Draw Distance : 590

I really think now it is a Shadow Detail options bug link coz before i re-edit this post i re-test this things and put Shadow Detail to “off” and nothing happen but with “just a touch” it’s a bonus bug for nvidia too (Nvidia > Intel oh no Nvidia fail too ^-^)

unfurtunately my game froze when i tried to save. So i just have a very old save. Sorry :frowning:

like not_owen_wilson said post your save and log for devs :wink:

@LaGrosseChoco Awesome repro steps! Thank you so much! Bug squashed for next build :smiley: