Going out of range in Fullscreen

Hi y’all!

My monitor can only display things at 60hz so whenever i go fullscreen, i get out of range of course. :slight_smile:

I just wondering if there’s any possibility of a Borderless Window option or a refresh rate setting? I can play the game no problem on Windowed mode, i just can’t bear the “pixelation” of being in windowed mode on my native resolution of 1280x1024.

I’m new and don’t know where to put the post so if i dun wrong, please move me into the proper category.

Thank you for the amazing work and keep it up!

Hey there @lavenki, welcome to the Discourse :smiley:!

I’m sorry but I’m not following here. 60Hz is the monitor’s refresh rate - what does that have to do with fullscreen mode? I have used multiple monitors with a 60Hz refresh rate without issue. What exactly happens when you go fullscreen that is an issue?

1 Like

i would up the resolution of my screen. Stonehearth will adept to you screen settings. refresh rate has no influence on window size. If going fullscreen puts you outside of your screen then your screen has the wrong resolution setting in my opinion.

Got me a 24 inch screen and currently 1920x1080 having no issue. Also a 19inch screen on the same resolution showing no issues. Even together there is no issue with the game not staying in its own frame.


@lavenki, is this the issue you are having, the game going off screen? If that is the case, you should be able to resolve this with a quick edit to your user_settings.json file.

Well, good for you, guys. However if that isn’t the case then i don’t know what is.

As i’ve mentioned, my current resolution is 1280x1024 and my LG Monitor maxes out to 60hz, so going fullscreen should expand it to said resolution (duh) :stuck_out_tongue: however whenever i select fullscreen, the monitor blacks out and says “out of range 170hz/60hz” (another duh), having experienced the same difficulties in the past, i’ve tweaked user_settings.json, NVCP and even played with other resolutions to no avail.

The other games that i’ve encountered i’ve either fixed through them having a Borderless Fullscreen setting or you can tweak the refresh rate to 60hz.

But i can play the game perfectly fine when it’s windowed aka "enable_fullscreen" : false, .

So, any solutions?

Thanks for the reply.

Couple more questions:

  1. What monitor are you using? Can you share the specific LG model?
  2. Which NVIDIA graphics card are you using, and what is the driver version number?
  3. Can you upload your user_settings.json and stonehearth.log? If you are able to launch the game full screen before uploading the log, that would be great - the log is overwritten each launch.