Glowing and transparent colors

Hi Community,

i have a question about the special colors like the glowing ones for monsters or the transparent one for water. When i create a model i only have to give te exact color type to the part of the model i want glowing or be transparent?

Or is there an other thing to do?

Found this colors for now


"#6FFF90" : “stonehearth:glowing”,
"#62FF00" : “stonehearth:glowing”,
"#EEFF00" : “stonehearth:glowing”,
"#FF6000" : “stonehearth:glowing”,
"#FF6600" : “stonehearth:glowing”,
"#FF9900" : “stonehearth:glowing”,
"#FFCC00" : “stonehearth:glowing”


"#56B8E2" : “stonehearth:water”,
"#3094AF" : “stonehearth:water”,
"#78C8DE" : “stonehearth:water”,
"#B4E7F4" : “stonehearth:water”,
"#63CAFA" : “stonehearth:water”,
"#7BCFF2" : “stonehearth:water”,
"#BEEBFF" : “stonehearth:water”,
"#3B9EB9" : “stonehearth:water”,
"#56B8E2" : “stonehearth:water”,
"#42A8C4" : “stonehearth:water”,
"#4AAEC9" : “stonehearth:water”,
"#2D849C" : “stonehearth:water”

1 Like

Hi there @pingu! I don’t know if this can help but, here’s what I did with my magma sword:

In the sword’s .json file under the components:

         "color_map"       : "file(materials/magma_color_map.json)",
         "material_maps"   : [ "file(materials/magma_material_map.json)" ]

Then on the same folder where the sword’s .json file is located, there is a another folder named materials. Inside the materials folder, there are two .json files namely magma_color_map.json and magma_material_map.json.

Inside the magma_color_map.json:

   "#F78911" : "startermod_items:constructs:glowing_blade",
   "#F7B211" : "startermod_items:constructs:glowing_blade",
   "#F79E11" : "startermod_items:constructs:glowing_blade",
   "#F7AB11" : "startermod_items:constructs:glowing_blade",
   "#F7C211" : "startermod_items:constructs:glowing_blade",
   "#F7C911" : "startermod_items:constructs:glowing_blade"

Inside the magma_material_map.json:

      "render_material" : "materials/glowy_voxel.material.json"

Then that’s it :smiley:! I just did what @BrunoSupremo taught me, if you have any questions I’m sure he can help.

Here’s the magma sword:


Hope it helps :blush:!


Ahh i see now how it works. You have to set the colors witch you want and than add the effect.

You used a personalized color_map right? But when i want to use the already existing one from stonehearth i only have to do something like this no?

    "color_map" : "stonehearth:color_map:water",
   "material_maps" : 

This one is used for the roadside shrine model

Well I believe so :slightly_smiling_face:. But honestly I’m still quite new to this. Maybe others can give you a better insight, sorry :sweat_smile:… I think @Relyss can help! (Sorry for if I bother you)

Ahhh no matter :smiley:

You helped a lot!! :slight_smile:
Maybe tonight i can try it with this settings and if its working fine. Otherwise i have to find a solution xD


Ahh tried the water trasparency but something seems not to work properly. the trasparency is also visible on the connected blocks. (See Plate model and Barrel)

someone can say me why it’s so? How i can solve this bug? @Stmpnk

screenshot 2017_08_17__22_40_27


I just returned from typing a lot of stuff.

Hmmm… I haven’t encountered anything like that before :confused:. Have you already got it to work?

unfortunately no :frowning:
i can’t understand the problem

If I understood the image correctly, the voxels with the water material makes it sort of “see through”?

I have never worked with transperency (have no idea how to set it up in the first place) - but, reading

from another post regarding the same issue, my guess would be that the Transparent Voxels “should” be one model, and the rest of the entity a different model?

yes it’s the same issue xD my post ahahah

exactly @Stmpnk, the voxels attached to the sides of the water are completely transparent.

Oh, I know ^^
Did you try setting them (the water parts and the non-water parts) up as 2 different models that get spawned at the same time?

So then it is not being rendered as intended, instead it leaves holes on the model. I just went to your other thread and you mentioned something about it working before in a different model. Did you did things differently :confused:?

EDIT: I gonna do some testing.

Yes tried also that but same problem :frowning:

Nono i used the shrines from stonehearth as reference but on my model doesn’t work

Oh… sorry I misunderstood :sweat_smile:. I’m gonna do some testing.

Wait, if I understand correctly:

  1. I can name new colours in glass_color_map.json
  2. Assign the glass_color_map.json colours to be rendered using the same material as water (transparent_with_depth.material.json) via assigning an alias in glass_material_map.json
    Side note: I’d copy all the files in case water gets a new rendering method later on.
  3. Enjoy my brand new stained glass windows.

Correct me if I’m wrong.

1 Like

No, you understand it right :wink:

But i have severe rendering Problems that i can solve with the transparency :frowning:
Maybe you can find a solution

Eh. Transparency. Something I still can’t get to work in my mod.

1 Like

in reality it’s really simple integrate them to the model. But something seems to go wrong during the rendering. I’m working on a solution but it’s not sure if i can fin one…

Otherwise i will write it down here xD