Ghost Curtains! (bug placing objects in a completed building)

After finishing a house, I added some curtains I’d gotten as a quest reward. On noticing that some time had passed without these being placed, I tried both ‘ib’ and ‘destroy’ commands to manually fix the issue, to no avail. This also happened when I tried to place festive lights (Frostfeast mod). I’ve experienced this bug before in un-modded versions of the game.

Steps to reproduce:

  1. Build a building.
  2. Once complete, try to place something on a wall.

Expected Results:
Completed placement of object/s.

Actual Results:
Eternal ‘waiting to be placed’ item.

Version Number and Mods in use:
Alpha 19.0 (release 687) x64 build, with Frostfest mod (2016).

System Information:
Windows 10.

Did you get any errors? Can the citizens reach it, notting blocking there path and stuff? Did you try saving and restarting?

This has happened to me, too. Try putting the item you want to place into storage, and see if a townsfolk takes it from there and places it.

1 Like

No errors appeared, clear path and there were plenty of the items in storage. Seems to be something about the walls in particular as I’d also placed items on the floor and these built with no problem.

I’ve tried a few saves and restarts as well across different games, but with no luck.

Had this to and seemed to be a priotity problem i think. I had a lot of things hang and for 1 they build a ladder but never went and hang it. After there was only placing items as thing for them to do they finaly hang it after i moved all the paintings to another wall xD