Game wont start Surface Laptop 3


I got a surface laptop 3 and the game won’t start, I’ve installed the latest updates by my manufacturer, but there seems to be another update which isn’t validated by them, which may be the issue.


I cant upload I’m sorry.

Versions and Mods:

I’ve just installed the game for the first time on this device and haven’t installed anything.

System Information:

Windows 10, Intel® Iris® Plus Graphics, Laptop Panel.

Have you attempted basic troubleshooting steps here: Crashing on start? Read this! UPDATED October 18, 2016

I’ve updated my drivers as much as allowed. I’m sorry but I don’t understand how to enter the given commands and am kind scared to as this laptop was a gift and i don’t wanna mess it up so soon. I can’t run compatibility mode, I don’t think its offered on this device as following the instructions doesn’t give me the options to run in an older windows. I can’t access .jnson files, as I opened it in notes and it doesn’t show any information. My graphics card isn’t in the gpu hierarchy, but neither was my previous devices, and this laptop is way strong than than device.

I think this may be due to the previously mentioned graphics driver update which my manufacturer won’t allow, but I have download the latest updates manually.

well the easiest thing to try would be getting compatability mode to work (since ive also had some bad experiences with this game and windows 10, reverted back to win 7 myself since win10 had lots of issues for lots of games for me)

so you tried

^ something like this to get compatability mode running and you get different screens so you cant select it?

I found the compatibility option, and ran steam in both windows 7 and 8 yet still the game won’t start. I ran steam on the compatibility mode though and not stonehearth itself as the option didn’t present itself.

I tested stonehearth.exe directly for both and it still doesn’t start.

hmm what happens EXACTLY when you try to start? does it start and then crash? or is it more a flahs of screen and then goes away without telling you anything?
(in the latter case, i know its a laptop, but do you have anything hooked up via USB? if so, try removing that and trying again. if that doesnt work and you have a wired controller laying around, try hooking that up and starting again, i noticed the game can get confused between webcams and controllers for some stupid ass reason…)

Nothing happens, the cursor does the loading circle for a second but then goes away. When I start it on steam it states its loading for a second, but then says play again.

check, did you try the usb thing? (both remove all plugged in usb things or plug in something like a controller?) in my case i need to keep my xbox controller plugged in to not have the same issue for instance. (because it thinks my webcam is a controller which makes it crash. if i unhook the webcam, no issue. but it want it plugged in so i got to keep an actual controller plugged in aswell)

I don’t have anything connected

well it might see the built in webcam as “plugged in” (yes, i know this sounds insane)
but if you have it, try plugging in a controller.

I tried with a ps4 controller and it brought be to big screen, and it looked like the game was starting, but then returned to the steam menu. I tried a couple times with the same result.

hmm. so it still crashes/closes. so its not this or not -just- this
inside stonehearths folder there is a stonehearth.log file probably, any chance you can show us that? (or at least the last few dozen lines of it? you can open it in any text editor)

2019-12-31 03:37:00.008806 | server | 1 | app | Stonehearth Version (x64)
2019-12-31 03:37:00.009811 | server | 1 | core.config | user id is ed48bb1c-30d1-4752-ad20-3df3e50ed6af
2019-12-31 03:37:00.009811 | server | 1 | core.config | session id is 76ad8a61-46a4-45be-b1b5-0efbf6cc96a5
2019-12-31 03:37:00.009811 | server | 0 | app | Steam present.
2019-12-31 03:37:00.009811 | server | 0 | core.system | Initializing crash reporter

is that everything? (if not, about 5x more would be nice)

yeah that’s all of it, I’ve never properly started the game on this device.

@moderators please help me I miss playing the game :frowning:

My drivers are all up to date now, and I’ve tried everything recommended, please bros.

2020-01-02 23:23:35.850046 | server | 1 | app | Stonehearth Version (x64)
2020-01-02 23:23:35.850046 | server | 1 | core.config | user id is ed48bb1c-30d1-4752-ad20-3df3e50ed6af
2020-01-02 23:23:35.850046 | server | 1 | core.config | session id is 05839415-058c-4b9a-b10b-640fceef379a
2020-01-02 23:23:35.850046 | server | 0 | app | Steam present.
2020-01-02 23:23:35.850046 | server | 0 | core.system | Initializing crash reporter

Here is all of the recent log.

Do you own other games on steam
Try if one of those works

All the other games I’ve played work. Mount and blade, spore, skyrim, ect. May the problem be because the laptop is touch screen?

Thst would make sense, the game seems finicky with Controll devices (see the aforementioned problem with webcam and the game thinging it’s a controller) might be the case here