Game wont launch

So I have just purchases this game, and i’ve tried a couple of fixes that I found, however nothing so far has worked. Im not getting any program starting, I just hit play and wait for a couple of seconds and it goes back like I never even pressed it. Im currently running on fully updated windows 10, all my drivers are updated, and i’ve verified my spec’s are for sure good enough.

I have a log, but it’s a very short one, not sure if its gonna be much help.

2021-09-03 00:41:38.589466 | server | 1 | app | Stonehearth Version (x64)
2021-09-03 00:41:38.589466 | server | 1 | core.config | user id is ccdd03c0-19d3-42b5-a189-f1526f0ed217
2021-09-03 00:41:38.589466 | server | 1 | core.config | session id is e18653a9-2634-4a60-8073-75a0bbe15c5c
2021-09-03 00:41:38.589466 | server | 0 | app | Steam present.
2021-09-03 00:41:38.593456 | server | 0 | core.system | Initializing crash reporter

There is no crash report document, i’ve checked and checked again, but nothing.

apparently the game refuses to run as a 64bit application on Windows 10, forcing it to run as a 32bit application has been reported to work in the Steam forums

I’ve looked into this a bit, and it does seem like it may be the issue, but I havent been able to fix this myself. I’ve read there is a way to change it into a 32 bit version, specificially using the “user_settings.json” file, but the only thing in that .json file is my user id.

Is there a special editor, or another way to change this that i may have missed?

Wow, so I found the issue. It was with the 64 bit version, but for some reason my user_settings.json file did not have any of the usual settings. Im sure this is because i was unable to do an initial startup of the game.

For anyone having the same issue as me, I found a very helpful post from one of the staff, its a copy of the user_settings.json file as it should be, and you just copy-pase into the user_settings.json file along with your user id, and change “force_32bit” to true, and badabing.