Game doesn't launch

Summary:

I click Play on steam, and then it seems for a few seconds like something is happening, then the Stop button just changes back to Play and nothing happened. So it basically acts like it never launched.

Stonehearth.log:

2022-08-06 02:10:28.623612 | server | 1 | app | Stonehearth Version 1.1.0.949 (x64)
2022-08-06 02:10:28.623612 | server | 1 | core.config | user id is 7e6991fe-b484-4e93-8e68-744640b84079
2022-08-06 02:10:28.623612 | server | 1 | core.config | session id is 75149ece-e6c7-4fa1-b253-0c7da885fe61
2022-08-06 02:10:28.623612 | server | 0 | app | Steam present.
2022-08-06 02:10:28.624615 | server | 0 | core.system | Initializing crash reporter

Attachments:

I’m a new user and would please like assistance.

Versions and Mods:

The latest version today, updated from steam. I can’t see since I can’t enter the game.

System Information:

Windows 11
Radeon RX 560
Processor 12th Gen Intel(R) Core™ i5-12400F 2.50 GHz|
RAM 32.0 GB

Have you attempted basic troubleshooting steps here: Crashing on start? Read this! UPDATED October 18, 2016

Yes I have.

Notes:

[Any additional useful information]

Ok nevermind I found the fix, for whoever needs to know what I did, basically I just went to the Stonehearth game files, there is a file called user_settings.json

Inside that file I just changed “force_32_bit” from false to true

1 Like

Ok so I’ve been playing with the 32-bit version for a while now since the 64 bit version doesn’t even want to launch, but now my game keeps crashing every few minutes while playing, I think today I have relaunched the game about 25 times from it crashing, and every time it sets me back to a previous auto save or manual save so I lose a lot of time catching up on things. Is there a way I can fix the 64-bit issue not starting the game at all? Please help and thank you

Ive had the exact same issue on startup it says running then stops. and in my user settings its just my steam id line its messed up.

I’ve had the same issue. Need help also! Thanks

Just curious, did you recently upgrade your CPU? I just updated mine a couple of months ago, and this is my first time playing SH with it. I have the 12600k…

Sorry for the late reply, I found the fix with by searching everywhere on google. So basically download this: /source/index.html
Extract the .dll files into your Stonehearth’s x64 folder and replace the files within the existing folder.
That should fix the 64-bit version.

I did upgrade my CPU, I have the 12400, but I don’t think CPU has anything to do with it, it’s that Stonehearth’s OpenSSL files are outdated or something like that. So the fix above should work.