Stonehearth wont launch


#1

Summary:

i press the play button on the steam application and my game says its running but then it doesnt launch and it goes back to the normal state. i dont see a screen appear what so ever.

Stonehearth.log:

2018-10-23 23:13:31.962838 | server | 1 | app | Stonehearth Version 1.0.0.893 (x64)
2018-10-23 23:13:31.963840 | server | 1 | core.config | user id is 179154db-1ff4-40ad-976e-bb633c84d22f
2018-10-23 23:13:31.963840 | server | 1 | core.config | session id is e811cd14-ab34-4573-93fa-a0ca5483dcf2
2018-10-23 23:13:31.963840 | server | 0 | app | Steam present.
2018-10-23 23:13:31.963840 | server | 0 | core.system | Initializing crash reporter
2018-10-23 23:13:34.492777 | server | 1 | resources | Modules are verified pristine.
2018-10-23 23:13:34.579797 | server | 0 | app | Running Stonehearth server on port 50186
2018-10-23 23:13:34.579797 | client | 0 | client.core | Connecting to local server…
2018-10-23 23:13:34.579797 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2018-10-23 23:13:34.585798 | client | 1 | game_engine | Initializing OpenGL
2018-10-23 23:13:34.598801 | server | 1 | mod radiant | lua controller lifetime tracking set to “nil”
2018-10-23 23:13:34.632809 | server | 0 | mod stonehearth.ai.service | enable_cpp_placeholders is on
2018-10-23 23:13:34.632809 | server | 0 | mod stonehearth.ai.service | enable_cpp_compound_action is on
2018-10-23 23:13:34.673324 | client | 1 | game_engine | Determining window placement
2018-10-23 23:13:34.673324 | client | 1 | game_engine | Selecting monitor at 990, 570

Attachments:

i cant upload attatchments

Versions and Mods:

Stonehearth Version 1.0.0.893 (x64)

System Information:

windows 10 (x64), RAM 16GB, gpu 1060 6GB.

Have you attempted basic troubleshooting steps here: Crashing on start? Read this! UPDATED October 18, 2016

yes, i have attempted.

Notes:


#2

Does it still happen after the latest update? The symptoms you mention look like a Steam issue that also happens with other games, that for some users the game goes back to sync and stops running shortly after starting it, but there can be many causes for that. :thinking:

Did you try adding an exception for the game and for the crash_reporter.exe to your antivirus?

Does it work if you run the Stonehearth.exe while logged out from Steam?