Game fails to launch; please assist

Directly after hitting “Play” in Steam.

I removed mods; verified files; upgraded, downgraded; uninstalled, re-installed; even uninstalled, deleted the folder from Steam’s common folder, and-reinstalled.

I don’t know what’s gone wrong. Please assist sad Kitty!

Sounds stupid, have you tried restarting your computer?

I’m fairly certain I have, but at this point, doesn’t hurt to try again. I’d love for it to be a simple fix and feel silly for not thinking of it. I will return shortly with result.

When in doubt, turn it off and turn it back on again…apparently twice if necessary. Thanks, mate


I wonder if something went wrong with Steam. Now it’s not relevant since you already fixed it, but, did you also try to run the Stonehearth.exe from the folder instead of launching it from Steam?

I did not think of that, no.

I suspect it might have been Steam; it immediately did an update that actually took a few minutes after I rebooted, which has me suspicious of it.

1 Like

No problem, I love how so many people forget about the simple off and on again but it works 90% of the time :smiley:

1 Like