Game crashing on start up

so i have the steam version and i cant play it it will crash before i can see the game open, i have deleted the game re-installed it, looked at the form and tried what others have done but nothing works so far help ;"(

There are a number of reasons your game may not start up properly. Try reading this page first to see if you can figure something out.

If that doesn’t help, please post a few things about your computer, particularly which version of Windows you are running (including any Service Packs installed) and which Graphics Card you have.


card : AMD Radeon R7 200 Series
Processor: AMD FX™-4300 Quad-Core Processor
windows version : 8.1 64- bit
1 TB left on my computer
8 GB of ram

The windows version sounds OK (some people actually have problems with 8.0 that can be fixed upgrading to 8.1).

Your graphics card certainly sounds new enough (it can handle the shaders and directx stuff it needs to). Have you tried doing a clean install of the latest graphics drivers from the AMD website? This link seems to be the right one for your card. Sometimes automatic installers cause problems with a graphics driver install that lead to the game not working. Sometimes its just that the drivers are a little old.

The third common possibility is with various programs that interfere with Stonehearth. The user interface of the game is displayed through a Chrome browser interface and some programs are designed to hook into that (anti-virus or web-protect software commonly does). There is a big (but not exhaustive!) list of such programs here. If you have one such program, you’ll have to disable it to run Stonehearth for now. They are looking into ways to fix that.

If neither of those things seem to be the case, there is still some things we can look at.


i just finished looking over everything i have updated the graphics card to the latest also have AMD Catalyst already, also the program list that could stop the game i looked over and didn’t find any of them, what else you got :wink:

1 Like

Well, now you’ve hit the basic trust level on the discourse, you should be able to upload some things here. If you look in your stonehearth folder, you’ll find a few useful files. user_settings.json, stonehearth.log and maybe a crash.dmp file. The first two are basically text files. Whats in them can often give some hints as to whats going on for us normal users. The third may be of help to the guys at Radiant.

If you can upload any (or all) of those three here, maybe we’ll figure something out. It’s worth a shot anyway.

Note: You may have to zip the crash.dmp if you have it to upload. Discourse is not a big fan of random file names.

1 Like (3.2 KB)

1 Like

Your user_settings.json is certainly malformed. It’s supposed to be filled with all the settings of your game and should be created with a lot more information the first time you run the game. Delete user_settings.json and run the game again.

If it still has only your a tag with user_id inside it afterwards, we know something else was wrong.


i deleted it then started the game it crashed, i then opened the the user_settings file it only has the tag still

also i haven’t played the game yet if that tells you anything, i have only seen its crash screen XD

What exactly do you mean by crash screen? Like you see a windows frame pop up and then it just shuts down again? Or do you get an actual error message?

windows fame pops up then a error message follows saying it must close

Is there any specific error code in there or just a generic message?

just a generic message

OK. It seems to me like the game is going through it’s basic “startup” phase (stoneheath.log has the usual stuff in it up until it would normally be fully loaded) and then getting knocked down by something. I feel like that’s hinting at something, but I really can’t think what atm.

I can’t think of any other easy steps right now, so I’m just going to mention @Albert, one of the Radiant developers that usually helps people with these problems. Hopefully he’ll be able to take a look and figure things out when he gets in to work. I think it’s nearly midnight on Sunday evening over there in California atm, so we’ll need to wait some hours for any help from there.

1 Like

okay thank you so much.

1 Like

@tazz1313 - Ok, drivers appear up to date and we don’t have a crash dump.

I see that you have an AMD FX series processor. Is anything in the system overclocked?

1 Like

hey albert im really bad at the inside of computer s and the specs of it, so i dont know the answer to that one.

no it is not, i know what you mean now.

Other than anti-malware programs, I can’t think of anything else to try.

I’m starting to wonder if we have an issue with the AMD FX series of processors. What brand is your computer / who did you buy it from?