Footmen are not using better equipment

I told my crafter to make better weapons and armours for my footmen and when they finished crafting the better equipments, they put it in the stockpile but the footmen won’t take them

Steps to reproduce:

  1. Promote a footmen Once every 2 day
  2. Give the first footmen with basic stuff but with some upgrade
    3)Give the second footmen with same upgrade as the first footmen
    4)Give the third footmen with the same upgrades as the first and second footmen
    5)Now give the the best Armour/weapon/shield

Expected results:
Footmen runs to the item and equips it

Actual results:
Footmen ignores the better equipments

For some reason my first footmen took them all, the second footmen took some of them and the last footmen did not take anything at all except a rough wooden shield and an Iron pike
The weapons I wanted the footmen was the Iron mace


Versions and Mods:
Stonehearth Alpha 10 version 345(64x). No mods are active or installed.

System Information:

Windows 8.1 | Intel® Core™ i5-5200U CPU @ 2.20GHz | 6.00GB RAM | 64-bit operating system, x64-based processor

(Are you proud of me @SteveAdamo :slight_smile: ?)


:clap: :laughing:


I’ve seen this happen with the spear thing… The only way i solved it was by demoting the footman and then deleting the spear… :smiley: Then promote them back again. :slight_smile:


My footman sometimes run away from the enemy…thats very funny but indeed a bug, Right? ^^

Maybe our bugs are similar and due to a false class configuration when promoting in some circumstances.

Footman Not really footman so they are:

  • not equipping correct
  • Not attacking but fleeing

I think that would depend on the footman’s courage levels… maybe?


[quote=“zigworf, post:3, topic:12779”]
spear thing
[/quote]wait… is the iron pike still at 1337 level…

nope, as @zigworf said, a low courage stat causes them to run :smile:


I don’t really notice this myself. Unless it is really close by, the footman won’t even think about a gear upgrade until it is put in a stockpile. They do eventually go get the upgrades though, one way or another.

Is this a new bug for you xXSlimeyXx, or is it something you’ve seen happen over multiple games?


I’ve had the same happen to me multiple times.

Generally to work around or quick fix it, I turn ‘all’ of my soldiers back into workers, then repromote them to soldiers again. Most of the time it solves the issue… At least for a time. :stuck_out_tongue_winking_eye:


My footman picked up better weapons up until they picked up the iron pike thing… Then they didn’t even notice the short sword…

1 Like

Hmm… the iron pike use to have a ridiculously high iLevel (meaning priority), but i thought they fixed that in the recent builds.


Maybe… I’ll have to check again…
Thanks. :slight_smile:

1 Like

i mentioned that earlier… it used to be 1337…

You’re confusing me with all the different comments :dizzy_face:

As far as I know:

  • The leet pike is already fixed from some time ago.
  • The armor / weapons must be in a stockpile before equipping them (just like promotion tools, hearthlings won’t pick them unless they are in a stockpile).
  • Are you sure that the equipment is really of a higher ilevel?

thats what i thought, but that doesnt seem to be the case in this report :confused:

could be that the other weapons actually are inferior, perhaps…

To put it simply, when I had experienced this issue a few times in the recent past:

I had one footman with a maul and shield. And 2 footmen running round with wooden swords!

While there were several mauls and shields in the stockpile (And they were definitely ‘in’ the stockpile)

  • So, to avoid confusion, direct answers to your questions! :smile:
  • Pike wasn’t involved. So I don’t know about that matter.
  • The armour and weapons were indeed in a stockpile.
  • And I’d very much hope that the mauls and shields are of a higher ilevel than a wooden sword. :stuck_out_tongue_winking_eye:

(At least, such has been the case in my incidents)

1 Like

I came across the leet pike issue in build 345. I haven’t come to that stage in build 375.
In my case my hearthling had a leet pike and there was a short sword in the stockpile… He didn’t even bother about the short sword, all of my other footman had short swords. When i demoted the footman with the pike, the other footman tried to take the leet pike… So i would say there is a priority issue… At least that was the case in build 345.

now is a time i wish i could delve deep into the code, just to find out whether the 1337 pike was still 1337 ilevel or not…

1 Like

nope it isnt anymore ^^ since alpha10 its fixed :wink: because of this i have remove my bugfix from the websites xD
for info its 10 ^^

1 Like

Like Wiese2007 said, it is currently set to iLevel 10 in iron_pike.json inside stonehearth.smod. That’s actually higher than all the other crafted weapons, excepting the Longsword.

Here’s a list of the weapons you can currently craft with some stats from their json files (don’t know how many of these actually work):
Wooden Sword: base damage 10, reach 1.5
Bronze Sword: iLevel 6, base damage 10, reach 1.5
Iron Mace: iLevel 6, base damage 20, reach 1.5
Bronze Mace: iLevel 8, base damage 16, reach 1.5
Shortsword: iLevel 9, base damage 18, reach 1.5
Iron Pike: iLevel 10, base damage 14, reach 2.0
Longsword: iLevel11, base damage 18, reach 1.8

There are also a few weapons you can get as rewards from the campaign, but they all have higher iLevels.

I have no idea why the Bronze Sword appears to be no better than the Wooden Sword.

BTW, you can check this all out yourself. The .json files are just text files with tags, so they are very readable. To get to them, you can copy stonehearth.smod to some other location, rename it to and then extract the files. Don’t leave the extracted files in stonehearth’s mod folder or they will override updated versions of stonehearth.smod (this is how mods will work).


thanks, i tried this before but it didnt work, however it does now :smile: