Footman Promotion and Medical Attention Bugs

Two potentially new bugs, one report.

First Bug: After today’s footman/party bug fixes, it now appears impossible to promote hearthlings into footmen at all. When you try, the game now just ignores you. I tried unchecking every task in the therapist UI and watched as it fell idle instead of executing its promotion activity. I then tried a different hearthling in case the AI hated the one I picked, same result.

Second Bug: I had a trapper looping between commands to get into bed to receive medical attention and go get something to eat. Eventually his stomach won out and he decided he wasn’t hurt bad enough to warrant the good doctor’s care. I’m guessing he healed enough while he was arguing with himself. But in the meantime, he was rapidly oscillating between in bed and standing next to the bed, and this behavior was reflected in the therapist UI’s Current Activity for that hearthling as well.

Steps to reproduce:

  1. Start a normal game.
  2. Play normally, but wait to promote a footman until after your first invader. Use Town Defense mode to defeat it.
  3. Attempt to promote a footman and observe it ignore you.
  4. Get a trapper injured by some hostile mob, but don’t kill him. Just hurt him enough to seek medical attention. Then see if he loops. Do this around lunch time, and don’t hurt him enough to make the decision easy. I’ll bet you can reproduce it.

Expected Results:
Bug 1: A brand new, shiny meat shield.
Bug 2: A hungry, but hurt hearthling that chooses personal health over their appetite.

Actual Results:
Bug 1: The same old, dusty worker.
Bug 2: Extremely confused hearthling that eventually chooses appetite.

Save Game

Version Number and Mods in use:
Alpha 14, Dev 2795, x64

System Information:
Win 10 x64
Intel i7 CPU
Nvidia Geforce GTX 965M


@sdee Paging you, because if this footman bug is reproduceable, the normal game isn’t very playable (for long, anyway) without footmen.


I have had no issues promoting footman…in fact I have two very brave footman you have reached level 6 protecting my village :smiley:. As for the trapper, no idea…haven’t created one yet.

That’s odd. Can you reproduce that in my save game, just to make sure?

Well, let me load it up!

Edit: No issue promoting with your save.


Okay. Thanks for testing. When I reload my game, I too can promote fine. So unfortunately, while I can attest to this happening, it doesn’t seem to be portable via save game. :confounded:

The only thing I can think of is that I used the town alert mode prior to having a footman in order to fend off my first intruder, and then later attempted to promote Beth and others without success.

Don’t know if that has anything to do with anything, but that’s all I can think of that was different this time around.


strangely enough I had this problem as well but when I tried to promote a fourth footmen it seemed to be ignoring what I was asking it. ill try to see if I can copy the problem and if I can ill post a save


Good bug reports! When you had trouble promoting people to footmen, did you have any trouble promoting people to other classes at that time? I’m wondering if it’s a footman thing or a promotion thing.

I wish I’d thought to test a different class in that same moment, but if it helps, I think I had promoted a worker to a mason very recently before this event without a problem.

Question: How does the town militia and Party 1 interact, if at all? Are Footmen members of both the militia group and Party 1, or are they removed from one and added to the other when they stop being a worker and begin being a footman?

If it’s the latter, this feels a bit like a party membership thing because I was using town defense and trying to promote a footman, and perhaps the issue has something to do with moving the Hearthling from the militia group to party 1?

1 Like

Hm, I’ll play with the militia/alert mode/footman stuff a bit, but they shouldn’t be related to not finding a talisman to promote with. Footmen cannot enroll in the militia, but all of the specific class promotion code activates only after the promotion is underway, literally as the talisman is at the apex of its animation. If they don’t run for the talisman to start with, that may be an issue with what their AI is doing when it is in alert mode, or right after.

If you’re so inclined, you can download debugtools. You can use it to comb the AI of an idle hearthling; sometimes shows useful info in situations like this!

1 Like

Would a Footman show as available in the promotion UI if a talisman wasn’t available? Or, are you saying that the likely reason they didn’t promote was because they could find it?

I was thinking the promotion command might not have actually been given.

Would some custom logging that tracks footman/militia/promotion changes be useful (assuming someone else runs into this too)?

Re: Debugtools, I’m not sure I could parse the syntax well enough for it to be too useful for me. My coding ability ends at HTML and CSS, a spattering of Ruby, and some light scripting. In short, I barely follow along on the dev streams. :slight_smile:

1 Like

Would a Footman show as available in the promotion UI if a talisman wasn’t available?


Or, are you saying that the likely reason they didn’t promote was because they could find it?

This would be my guess!

I was thinking the promotion command might not have actually been given.

But this is a good guess too.

My coding ability ends at HTML and CSS, a spattering of Ruby

Haha! That’s quite good enough. Debugtools is a mod that adds a bunch of tools to the upper right corner of the UI. The AI tool shows a tree of what the AI is thinking (with colors to show what is stuck). Sometimes, a screenshot of the AI tree can be useful to help us figure out what the hearthling is doing (and why it got stuck trying to do what we wanted it to do.)


Sweet! …Linkage? :slightly_smiling:

Download and put in your mods folder!


Nice. Thanks! I’ll include anything relevant from it in future bug reports, screenshots, etc.


Silly question, but once you’ve added it to the mods folder (and removed the -master from its filename! :P), what else do you need to do to get the UI elements to appear? Because just running game with that file in place doesn’t seem to do anything, and there are no relevant checkboxes in settings to make them visible… I’m running A14 D2797 if that matters? @jomaxro, your thoughts?

did you rename the zip to .smod?

Well, is it a smod, or a folder. If it is a folder double check that there isn’t another folder inside of it. It should be ../mods/debugtools/bunch of random stuff

Sorry, should have mentioned that. Yes, I renamed it to .smod. …and before I removed the -master from the filename, the engine error text told me to rename it and try again. :slight_smile: Clever Yang is clever.

1 Like

Hmm, do you happen to have 7-zip installed on your computer?