Fighters Not doing Anything

My Fighters Will not leave the farms, even if told so or even when their is an enemy attacking the town in their sight of range. They don’t even Sleep or eat. They just walk in the farm and nothing else.
Steps to reproduce:

  1. Save your game
  2. Quit to main menu
  3. Reopen your World

Expected Results:
To do their jobs and protect my Town
Actual Results:
Stay in Farms and walk and don’t leave for anything.
Affects Gamplay

Version Number and Mods in use:
Alpha 17 593
System Information:

Welcome to the forum, @Ruthless_Freak :smiley:

Do you have the “Job” checkbox unchecked for your fighters, perhaps?

It’d be helpful if you can upload your savefile so we can take a look. If it’s more than 10MB you’ll have to use a free hosting site like Dropbox or Google Drive and share the link here.

I found the problem! It was because i had to many fighters in one group. I think the max you can have without it bugging out like this is 8 because when i put my 9th in they do nothing.

I’ll ask @Albert about this when they come back. Thanks for reporting! :smile:

I had something similar happen today as well. My cleric and one of my footmen decided they’d only patrol the farms as well. I only had 6 in a group.

1 Like

I actually just had this happen with only 5 fighters, my archer and strongest fighter decided to stay in the fields while the other three tried to take on a swarm of tough enemies… I didn’t realize it was a glitch though until I saw this thread.

I’ll try moving one of the fighters from the group and see if that fixes it. Could be related to one glitching out and causing them all to freak out, and removing one reverses the glitch? I dunno. Just an idea for why removing the 9th seemed to work… xD

Wow thats Super Weird. I just use 2 Different Groups of 4 now Cause the 9th died. But its all good! Hopefully it gets fixed :smiley:

1 Like

The last patch notes mention “Fixed bug where a combat party could split into multiple patrol parties”.

There might be some glitch caused by this. If any of you have a save where this bug is happening, and when removing a footman from the party fixes it, it will be useful for @Albert to debug this :slight_smile:

I have a save file on this matter. - Google Drive

Since I realised too late it was going the wrong way I can only deliver this one. But since nobody else posted any I thought atleast it’s something.

When you load this save the soldiers who did fight allready died, the ones not fighting are still (barely) alive. I tried changing combat groups but that did not work