Error with AI during 'Eating'


#1

Summary:
On a brand new save as of yesterday, within the first hour, there were errors whenever Hearthlings would finish eating

Steps to reproduce:

  1. Have more than 7 hearthlings
  2. Wait for them to go to eat
  3. Check the stonhearth.log file after noticing heavy lag in game

Expected Results:
To not error or lag

Actual Results:
Game fps slows down and log file is spammed with errors
2019-01-08 01:38:41.703883 | server | 1 | ai.execution_frame | (8003 Tippy Addion) [stonehearth:get_food] (8003 Tippy Addion) (stonehearth:get_food) ignoring bad frame transition to “unit_ready” from “finished”

Attachments:
With Mods
Version Number and Mods in use:
Version 1.1, ACE 0.9.2, Fisher + Archipelago, Super Mod X, Bigger Backpacks, Kai’s Monkey Traits 3.51
Templates: TMD Tier2, Riallwood
stonehearth.log (217.9 KB)
1546929778657.zip (6.3 MB)

With only ACE installed:
Version Number and Mods in use:
Version 1.1, ACE 0.9.2
stonehearth.log (126.8 KB)
1546984796994.zip (6.2 MB)

When no Mods are installed:
Version 1.1
Same error - FPS is not affected, unlike before
stonehearth.log (51.2 KB)
1546987643752.zip (4.5 MB)

System Information:
Intel i7-4770 @ 3.40ghz
16 gb RAM
GeForce GTX 750


#2

Replicated AI error after uninstalling all Mods and only having ACE
stonehearth.log (126.8 KB)
1546984796994.zip (6.2 MB)


#3

Have you tried replicating without ACE? Just wondering, 'cause I don’t remember if we changed anything related to that – but I’ll take a look anyway :stuck_out_tongue:


#4

That’s a harmless warning from the base game, shouldn’t have side effects.

If you notice it says “ignoring bad frame transition”, which means it’s not running error code, just letting the AI proceed.

There must be something happening, since it’s logged way too frequently, but should be harmless.


#5

This is a save without any mods installed and it is still occurring, however FPS is not being affected like it was when mods were installed (including ACE):

stonehearth.log (51.2 KB)
1546987643752.zip (4.5 MB)