Endless effect loop after demolishing buildings

After destroying the roads I made in a mine I was starting, the dust left behind is hard to see through, and never seems to go away. The save file I have is after I’ve removed the road, I didn’t hold onto a save from before it happened unfortunately, but the issue is very visible in my save.

Steps to reproduce:

  1. The dust is already present in the save file. Simple active the slice tool, go to 44m, and you’ll see the endless dust storms.

Expected Results:
Probably shouldn’t be so much dust. Especially since all I destroyed was a very short road.

Actual Results:
Too much dust, for way too long.


dust.zip (7.9 MB)

Version Number and Mods in use:
Alpha 18 Test Version
Stonehearth 0.18.0 (develop 3092) x64 build

System Information:
Windows 10 Pro, AMD FX-8380 4.01GHz 64 bit, 16GB of RAM.

I’ve seen this too (I mentioned it on another thread). It’s the destroy effect playing in loop (in my case it happened with a house).

If the road is still somewhat visible, try to tell them to destroy it again, after a save reload. It might stop the dust.

Same issue - persistence dust after destroying road blueprint, did not go away after reloading save.

My guess would be that the GM is trying to get the road to hit the ground by making it fall, but the road will get covered with the original ground and will fall through, creating an endless loop

Perhaps the GM is trying to make a object fall when it should just be removed?

But i’m no dev or coder or programmer that’s just my conspiracy :wink:

A post was merged into an existing topic: Loop of errors while demolishing building

Hey guys,

When i was playing today, i tried demolishing a building and now im stuck with an never ending “explosion”.

These are the Engine errors related to the issue:
develop-3109 (x64)
…hearth/components/scaffolding/scaffolding_region.lua:714: attempt to index a nil value
stack traceback:
[C]: ?
…hearth/components/scaffolding/scaffolding_region.lua:714: in function ‘_start_erasing’
…hearth/components/scaffolding/scaffolding_region.lua:227: in function <…hearth/components/scaffolding/scaffolding_region.lua:220>


develop-3109 (x64)
c++ exception: lua runtime error
stack traceback:

Tried refreshing UI / saving / loading nothing seems to fix it.

Dont know if i can recreate the bug, The game was laggy when i tried to remove the building plans, so i removed it twice and in the middle it also tried to autosave.

Hope it helps.

Welcome to the forum, @El_Gieter :slight_smile:

Was your building not finished when you clicked on Remove? I’m just wondering, since your error mentions the scaffolding… :confused:

I have a permanent cloud of smoke from using the “Remove” tool on blocks I was testing for blending colors to the cliff. it won’t go away even after saving and reloading.

I had placed a couple blocks, and used alt-c “ib” to build, checked for color maching and then “removed” them while the game was paused, ran game and the poof cloud won’t go away.

1 Like

I was still in pause mode when i pressed build, yet i saw i made a mistake and removed it before they started building. At least if i remember correctly.

And it was also with blocks, same as Unatan2 had.

1 Like

A post was split to a new topic: Loop of errors while demolishing building