Loop of errors while demolishing building

I had this thing happen just now when i tried to destroy one of my houses :slight_smile: had like 30 errors of “start_thinking” and scaffolding so i thought i remove the house and put it back again but this was what i got :smiley:

Looks like some Yummy Chocolates
This kept happening over and over creating more and more blocks of chocolate and dust keept spawning

Latest Alpha 18 3116(m)
Settlement Decor
Café Mod
Jomaxro Doorways

All updated to latest to work with Alpha 18

I’ve split this here since it’s a different error than the one they fixed.

Might as well merge my post, which might be more related to this than to the endless dust effect.

@Banto, could you upload a savefile, or your stonehearth.log so that we can see what the error is saying?

I have steps in this post, with which I’m able to reproduce the endless loop (last step would be to remove the building, as I mention at the end):

I tried to make a save for it, but it seems after saveload it only keeps the dust effect in loop, and it can be fixed by telling them again to remove the building (on latest A18).

So I’m only able to reproduce it if I don’t save. I had it happen with other structures and just by removing a wall (which is discussed by @Banto here: Revert Tool not Working. Can’t destroy walls ).
However this bug doesn’t happen all the times, but with my steps it’s quite consistent and throws this error:

    develop-3109 (x64)[M]
...onehearth/components/building/building_component.lua:579: attempt to index a nil value
stack traceback:
	radiant/modules/common.lua:237: in function 'report_traceback'
	radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
	...onehearth/components/building/building_component.lua:579: in function 'fn'
	radiant/controllers/nonpersistent_timer.lua:56: in function 'fire'
	radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
	[C]: in function 'xpcall'
	radiant/modules/common.lua:257: in function 'xpcall'
	radiant/controllers/time_tracker_controller.lua:82: in function 'set_now'
	radiant/controllers/time_tracker_controller.lua:103: in function 'increment_now'
	radiant/modules/timer.lua:13: in function 'instance'
	radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
	[C]: in function 'xpcall'
	radiant/modules/common.lua:257: in function 'xpcall'
	radiant/modules/events.lua:285: in function 'trigger'
	radiant/modules/events.lua:398: in function '_trigger_gameloop'
	radiant/modules/events.lua:446: in function '_update'
	radiant/server.lua:62: in function <radiant/server.lua:58> 

Well it’s doing the same in the template “Bastide” I uploaded on the topic No doors/windows… loops of errors and dust

1 Like

Any good suggestion for easy to use file up loader since discourse max seem to be 10MB?

One thing with this house is that i started to build it and at the end where everything was done except they refused to put some furniture maybe windows i did “ib” in the console to make it 100% done they refused to remove scaffolding from this house and when i tried demolish it just broke into this loop.

I think i did try demolish this house before just for fun and it worked that time but was maybe 2-3 versions ago.

They mentioned lately that “ib” was a bit buggy with big structures. In any case the loop is real.

About upload files, I know of Dropbox, Google Drive, Filedropper, and… I guess the other ones are more oriented for pictures >_<

Thanks :slight_smile:

Here is the Save

Here is Template for the specific House
Dropbox - Link not found

Demolish this one to see the effect. It’s placed on the save at the farming area of the Town

1 Like