[Dup] Trapper Options Glitching


#1

Title: Trapper Options Glitching

Summary: I was playing around with the trapper and was attempting to replicate the bug where you can harvest more animals than will fit in the bag, and the extra will disappear. However, when doing so, I managed to somehow semi-permanently stick a red “X” and crosshair to the ground, which resulted in scads of other glitchy behavior (multiple markers for the trapper to move to, inability to control camera) until I was able to disentangle myself from the trapper.

Steps to reproduce:

  1. Promote a settler to trapper.
  2. Trap a full bag’s worth of animals.
  3. Select “option 2: set trap”, and attempt to trap an animal that is too far away so that you get the red “X”, not the crosshair.
  4. Select move, and put the marker close to where the “X” is
  5. Re-select “set trap”. If this worked, the “X” on the ground will become a richer shade, and trapper behavior will become glitchy. You’ll know it when you see it.

Expected Results: Trapper would move closer and then set a trap.

Actual Results: Movement markers and trap markers were set multiple times, semi-permanently, and camera couldn’t be controlled.

Notes: Sorry if this didn’t make much sense, it’s sort of difficult to describe exactly how it worked.

Attachments: Stonehearth Alpha 2 (r52): Trapper Bugs here’s a video, timestamp at around 5:30, if that’ll make anything clearer.

Versions and Mods: Alpha 2 r52, no mods

System Information: Windows 7, 64-bit OS, i7 processor, 8G of RAM


#2

I moved a post to an existing topic: Multiple Bugs While Playing Alpha 2.0


#3