Dining hall has no door

After placing the “Dining Hall” blueprint, the door disappears. Before selecting the location, the door is visible on the blueprint. After the location has been selected, the door just vanishes.

Steps to reproduce:

  1. Place Dining Hall

You can simply place one before starting the construction. Still annoying tho.

Version Number and Mods in use:
Alpha 15 (Release - 537). No mods.

If you build another one, does the door still disappear ?

I had this one too. But after placing the first one, all following placed ones did have the door than.

Soo…I cannot replicate this. I tried in my test world, I create a new game, I ended up creating every possible combination of games (Ascendency vs RC, Temperate vs Desert, Normal vs Peaceful, 8 different games) and each time the dining hall placed just fine with a door. @8BitCrab, can you repro this?

not with the dining hall, but i had it happen yesterday with the tiny cottage, though after it happened i couldnt get it to happen again… then i saw this report and tried again but still couldnt get it to happen… :confounded:


So there’s something there, but it’s sneaky! Maybe @sdee or @not_owen_wilson know something about it.


oh wait! just tested again and had it happen! dont have clear repro steps yet, i’m going to poke around with it some more…


i figured it out (with help/confirmation from @jomaxro) the bug is actually directional,

  • first turn on the F11 debug key so you can see the axes of everything
  • rotate the template so that the door is facing towards the red axis
  • place the template
  • see that the door isnt placed with the template

these repro steps are more for the team, as they need debug keys enabled in order to make much sense, if needed i can provide a screenshot.

hope this helps :slight_smile: