Building deconstruction (windows and doors)


#1

A quick question: I’ve noticed that when hearthlings disassemble a building, its windows and doors just “disappear”. We see a hearthling removing a window, but it never gets into the stockpile. Is it disassembled into basic components (in my case wood) or destroyed?


#2

Interesting question. @not_owen_wilson should know.


#3

On a (somewhat) unrelated note. There is no indication in the game whether the building is being constructed or disassembled (aside from hearthlings’ current jobs’ panel). After you’ve clicked “Remove” Pause/Build button only pauses/continues disassembling. There is no visual mark (unlike ladders or furniture where there is always a hovering icon if this item is being removed). Also once you click “Remove” there is no way to revert the process. I understand it’s probably difficult AI-wise to switch back and forth between building/tearing yet it would be great to have such an option :wink:


#4

Could be worse, for some reason my dining hall built with no door. I only noticed it when one of the Hearthlings (who had managed to build himself INSIDE the building) died of starvation. I told them to disassemble it, and they started from the roof down. Of course one of them fell inside, and the rest won’t continue on because he’s tied up the “next” disassemble step…


#5

that sounds like this bug,

http://discourse.stonehearth.net/t/dining-hall-has-no-door/20964?u=8bitcrab

can you manually build a ladder (hotkey L) out of the building so that he can get back to deconstruction?


#6

Sometimes it happens with other templates as well (including my own). Don’t know how to consistently reproduce it.


#7

i know, i first had it happen with the tiny cottage.

i actually have repro steps for it in the other thread. long story short, the bug is directional…


#8

Yup! That’s the one! I actually just chalked it up to “That’s an alpha!” and gave up that save, and started over.


#9

Have you tried destroying the dining hall?
In the Submenu where you find Harvesting and Mining you can use the button with the X to destroy stuff. I used that to get rid of an unfinished pillar once which was in itself a building. I haven’t tried it on entire buildings but maybe it works?
You won’t get any materials out of it though.