[Bug] worker stop deconstructing a building

Steps to reproduce:

  1. Select build and design
  2. Once selected, select the building
  3. select remove

Expected Results:
I expected the building to be removed

Actual Results:
the build was deconstructed halfway

Welcome to the forums @dedarkknight :smile:!
Could you elaborate a bit? I haven’t understood it well.

You placed a template to be constructed, and when it was complete, you clicked on it and selected remove but the building was left only half-deconstructed, is this it?

Did the workers stop other tasks too? Or did they stop deconstucting to focus on other tasks, maybe?

1 Like

This bug started out where my Hearthlings wouldn’t finish a wall. I was able to deconstruct it and I tried rebuilding it slightly different but again they wouldn’t build wall. I then tried to deconstruct it. Then they just removed the scaffolding but afther that I could not deconstruct any buildings I previously made. I think if I make a new one I can deconstruct that.

I know there is an update for the game, but I did not receive a steam update.

User id: fd8132e0-446a-11e5-8838-003067c92bea

Here is a youtube video of the event:

I looked for similar topics but only found a door irremovable and not everything.

I’m using version: 0.10.0 Alpha_10_5 10 x64 build


You can update to the latest version by following the steps at the end of this page.

(This will be the unstable version, so there may be a few more bugs)

edit - As far as I know, you can’t deconstruct a building once it’s already been built. As solace though, I can tell you that you can cheat by selecting the wall you want to delete, opening up the console with ctrl + shift + c, and typing in “destroy”

1 Like

I had a fully built house yesterday, and by a simple mistake i had accidentally clicked something along the lines of remove building, and all my hearthlings like flies on crap ripped that house apart…


They were only listening to commands… “User error” as my fellow developers would say :wink: