Building is broken


#1

Fresh install r549 64bit, new game.

UPDATE:

  1. I got the second dining hall furniture to behave by carefully un-placing pieces that were double placed and eventually the hearthlings started putting things where they belonged. The default placements were somehow scrambled.

  2. Having unscrewed the second dining hall, I tried removing the defective first dining hall and here’s the error message:

release-549 (x64)
.../fixture_fabricator/fixture_fabricator_component.lua:76: attempt to index a nil value
stack traceback:
	[C]: ?
	.../fixture_fabricator/fixture_fabricator_component.lua:76: in function 'set_teardown'
	...ruction_progress/construction_progress_component.lua:97: in function 'set_teardown'
	stonehearth/services/server/build/build_service.lua:113: in function 'cb'
	stonehearth/services/server/build/build_service.lua:82: in function '_call_all_children'
	stonehearth/services/server/build/build_service.lua:78: in function '_call_all_children'
	stonehearth/services/server/build/build_service.lua:78: in function '_call_all_children'
	stonehearth/services/server/build/build_service.lua:110: in function 'set_teardown'
	stonehearth/call_handlers/build_call_handler.lua:25: in function <stonehearth/call_handlers/build_call_handler.lua:23>
  1. The rotting food mechanic should really impact the use of the food. Both the cook and eating hearthlings should use oldest stock first.

ORIGINAL POST:

Got to adding buildings. Bunk house built fine. Tried to build dining hall. Failed to finish the construction and did not leave space for (or install) a door or the second lamp, even though those parts were in a chest. Tried to remove the building and got an exception popup. Building won’t go away. Tried to build a second dining hall and this one built fine but only two chairs and one table were ever placed. The remaining furniture was in the same chest as before. Tried placing the furniture manually but no hearthling responded. Placed chairs around on the ground outside the building and only one was placed successfully. I could then have it moved into the hall. That was it.

Special complaints:

Chests are almost worthless because you can’t move things in and out directly or place things from them. So, they just get in the way. They also should default to allowing NOTHING in, not everything, since once you place the chest, the hearthlings rush to throw every kind of crap in there and you can’t manage the contents.

This is a special instance of the still crippled resource management where you can’t move things around once they are ‘stored’.

The ‘rotting food’ mechanic is ok but there should be a better way to clear it than manually clicking each crate. I would be fine with the hearthlings taking out their own trash instead. It just needs a way to know it’s happening (a garbage dump? Compost pile used by the gardners?).


#2

You can select that in the menus … somewhere … just look through the options.


#3

Thanks. Found it. Much better.


#4

Also, you should be able to place items in chests/crates using the Place Item tool (hotkey p) in the build menu. It looks like a chair with an arrow pointing at it.


#5

I want to get things OUT of chests without having to destroy them. You should be able to move things in and out of storage easily if you want to keep them organized.


#6

I might not be understanding then…let me grab some screenshots and make sure we are on the same page.
Here is my test world, with a small crate:


Here are the crate’s filters:

Here is the crate’s contents:

Here is the place item tool (menu is circled in red):

Here is the clay bed being place:

To place the bed all I did was click it from the Place an Item list, and then click where I wanted it to go in the world. Is this what you are looking for, or am I not understanding still?


#7

That’s fine for placeable items. What about everything else? Like the pot pie in your chest? I would even be somewhat ok if the undeploy command (red up arrow) allowed you to recover the chest by emptying it out on the ground as happens if you destroy the chest. There are a universe of items you have no control over once they are ‘stored’.


#8

The pot pie gets eaten by my Hearthlings…it actually happened while I was trying to take the screenshots, I had to forcibly move some Hearthlings. If an item is not placeable, that would imply to me that it is a crafting ingredient, tool/weapon/armor, or food, all of which are used by Hearthlings when needed.

You can empty the chest by turning off all the filters, but the Hearthlings will not remove the items unless they have a place to put them (like another crate or a stockpile). There is no way to force Hearthlings to take items out of a stockpile and leave them on the ground.


#9

I have not seen things removed after turning off filters. new additions in that category stop but what’s already there stays there. I will experiment with this and see if the behavior is now what you describe. That would be progress.

Thanks.

UPDATE: That works. It also works in storage ‘fields’ as well. Still not very fine grained but it helps. It sure would be nice to have a wiki or a manual for this game.