Developer Commands Failing to Work (develop-3380 (x64)[M][C])

Hello. I’ve been lurking on this Discourse since Alpha 11 and I personally love the game as I just love to build and watch the day to day actions actions of the Hearthlings.

One of the things that help me a lot in many situations is using the console commands as well as the dev tools at the top right to basically make sure everything is working nicely. While this is fine and dandy, I’ve noticed a brand new bug with the dev tools themselves.

The console command literally does not work in this current build of the game. And I have a feeling its how the game now sees or positions the attributes of the hearthlings as well as other minor data pieces.

The stamper tool and other helpful little options in the top right eight do all work, it just seems the console itself is completely bugged and refusing to work.

I don’t know if this is one-case issue or wide spread, so I wanted to report it.

1 Like

Hey there @Cura, thanks for lurking around the game so long!

I just tested it - and I have no issues with the console on my system. Looking at the version number you provided - there are two “flags” there, M & C.
M simply means you have mods - nothing inherently wrong there. The C worries me, as it means you have a mod conflict: you have both a smod and a flat folder with the same name. Can you check you mods folder and see what might be duplicated there? The most likely explanation is that you extracted one of the Stonehearth mods - perhaps debug tools - and now there are two versions of it. Steam updates the smod - but the game prefers flat folders - so this can cause strange issues like this one.


Thanks for the response and clarification of the M and C for me. From in my mods folder, I have no dupe mods appearing for me.

The mods I have loaded are;

  • archipelago biome
  • canyon biome
  • debugtools
  • desert transition temperate biome
  • footman sword
  • homf
  • patrol mod
  • settlement decor
  • yang armoury
  • yang decorations

(I excluded the required ones such as Stonehearth, Radiant, and Rayyas Children since they are base requirements)

Still, I don’t know what is going on it. There is no folders and they are all smod files.

Interesting… :thinking:

OK, two more ideas. One less drastic than the other.

  1. Try disabling all the non-Stonehearth mods. You should have only stonehearth, radiant, rayyas_children, and debugtools enabled. See if commands work in a new game with only default mods.
  2. If commands work there, then one/some of the mods are confliciting/have a bug and we’ll need to troubleshoot that.
  3. If the commands still do not work, I’d suggest trying a clean install.

Clean Install:

  1. Launch Steam.
  2. Right-click Stonehearth and click Properties
  3. Click on the Local Files tab
  4. Click Browse Local Files...
  5. If you have saved games or templates to save, complete the following. Otherwise, skip to step 6 below.
  • For saved games, copy saved_games to another location, like your Desktop.
  • For templates, copy saved_objects to another location, like your Desktop.
  1. Go up one directory level to the common folder.
  2. Delete the Stonehearth folder.
  3. Close Windows Explorer and return to Steam.
  4. Right-click Stonehearth and click Uninstall...
  5. Once removed, right-click Stonehearth again and click Install Game...
  6. If you backed up saves or templates in step 5 above, do the following. Otherwise, skip to step 12.
  7. Right-click Stonehearth and click Properties
  8. Click on the Local Files tab
  9. Click Browse Local Files...
  10. Copy the backed up folders into Stonehearth folder.
  11. Close Windows Explorer.
  12. Launch Stonehearth
  13. Finally…
  • If this works, great! Try re-downloading the latest version of your mods and try again. Please let us know the eventual resolution so we can mark this as resolved.
  • If not, please let us know when commands stopped working - never worked, worked before mods, etc.

Apparently I did the first resolve and nothing happened. Curiously, I removed the smod and replaced back in and it fixed itself; which is very good because now its just a [M] next to the dev build number. There is no [C].

However, another question. Was the add_gold and set_attr commands removed in this build of dev tools? I noticed a lot of commands are completely removed and the text is very large now for the commands (unless I am using an out of date devtool smod)?

1 Like

It sounds like debug tools is disabled…while the console will always open, most of the commands are part of debug tools, so that must be enabled for the commands to exist.


Alright, its all fixed now. Thank you very much for your help, @jomaxro!

1 Like