[dev2083] Double village, double berry-bush

Not sure if I’m in the right thread. But I get this bug in the latest steam branch (the 64-bit one). By spamming on the Embark button I can click it twice and get two flags to place down.

http://imgur.com/2PvX8yh

1 Like

I raise your double village with my quadruple village :open_mouth: !

To reproduce, simply spam that Embark button on the site selection screen. Each time a flag is placed the “name your settlement” popup appears, but at least it defaults to whatever the first one has. This also caused a couple of error messages to pop up on the loading screen (forgot to take a SS etc though, sorry :frowning: ) and made the progress bar disappear on said loading screen (though the text in the loading bar still went through its various options).

3 Likes

Bumping because I’ve been having lots of !FUN! crashes trying to play whilst doing this…

8MB save game (in .rar archive) here

I’m running Windows 7 x64 with an Intel Core i7 CPU (3.2GHz), 12GB RAM, GeForce GTX780 (drivers v344.65); Stonehearth build is 2143 x64.

Nothing much to report as to the bug, beyond it happening every few minutes. Game freezes up and then it’s straight to the desktop.

Now, quite possibly the crash is my fault (you know, what with clicking Embark three times and having duplicates of half the trees etc on the map…), but I’m going to go ahead & name drop @Tom / @Ponder / @sdee on the off chance they want to take a look at the save game linked above.



Edit: From the same game:

Goblins can’t spawn on the small hill I’m starting on, so possibly that’s what’s causing this.

1 Like

i have a found a bug in Stonehearth v0.1.0 dev.2148 i have click 2 times on de banner when i begon and i could make 2 places to settle down olso i get 2 carpenter saws and trapers knifes and the dobble amount of cidecens (i don’t know how to spell that word)

sorry i mean i have click 2 times on the embark buton when you chose your place

ahhh, thanks for the clarification! :+1:

I may be mistaken, but I thought there was a similar report floating around… I’m sure @Relyss will dig it up… :smile:

Even though it’s a bug that’s a nice way to start out with a bigger town :wink: Might have to exploit that one before it gets fixed :smiley:

2 Likes

I tried it and it does create two camps, but also interesting to note, the meter (Lag meter?) in the lower right next to your Pause button is non-existent in both his and mine.

@SteveAdamo
Well, I found this:


2 towns in 2 worlds in one world, as opposed to this problem of 2 towns in one world.

1 Like

@coasterspaul nope ^^

here it is [dev2083] Double village, double berry-bush

2 Likes

The one above has two of everything, trees, berry bushes etc it seems, this one Jordleek mentions just creates two of the blue “Click me to start” banners, the double clicking you do is on the map screen, double clicking that red Embark button causes the two banners

2 Likes

hmmm … thanks for digging around folks! :+1:

I suppose we’ll leave this one on its own for now …

1 Like

Yes, we’ll leave this one. I managed to find a resolved one about a specific release, but it’s not the same bug I think.

3 Likes

That’s the one @Wiese2007 :slight_smile: :

If @SteveAdamo or @Relyss wish to merge these, it looks like exactly the same bug (can confirm it too, for what it’s worth :stuck_out_tongue: ).

2 Likes

And the winner is … @Relyss Relyss she have the correct bug :wink:

@Teleros thats the one i have posted and its not the correct - because in this bug is all duplicated :wink:

1 Like

It sounds the same:

My highlight.

Look at the opening post of the topic we both linked, and @Krovikan’s post in the topic (and mine etc). I don’t know if @Jordleek has any double berry bushes in his game (none in the SS he posted), but given the whole “spam embark button” thing it looks like the same bug.

5 Likes

euhm i tried it with clicking embark alot of times.
i got 4 towns, but my trees and such were on top of each other and inside of another o.O

3 Likes

[quote=“PulseLazor, post:14, topic:10448, full:true”]euhm i tried it with clicking embark alot of times.
i got 4 towns, but my trees and such were on top of each other and inside of another o.O[/quote]
Yup, that’s what I’ve had a few times now :slight_smile: .

3 Likes

also tried ^^ works perfect :wink:

1 Like

Ok, thanks for the confirmation. Merged :+1:

2 Likes