Delicate AI: Hearthians Cease ALL Functions & Ghost Workshops

So a few time I’ve played I’ve noticed a few bugs, but the biggest is when the AI of the Hearthians/citizens breaks. If there is more than one building being built, they cease to function. Even footmen stop patrolling. Occcasionally the carpenter and mason will freeze in place in front of theri workshops, a crafted item in hand.

Sometimes this can be fixed by forcing them to move with the “Call to Arms.” Other times I have to change the Hearthian’s profession. And as of late, nothing helps at all. As a result, they continuously get hungry and refuse to act upon their needs.

Of course, at this point I had 12 citizens and I had gotten to the next game month.

Another issues, workshop ghosts. Sometimes when I put down workshops, all that is put down is a ghost or footprint. This had made making workshops increasingly difficult with the latest test candidate.


Thanks for reporting. The bug with the stuck workers is already known, they get stuck while carrying something (not necessarily) and eventually starve to death.

For your other problems, I guess you have all the needed resources to place the workshops and build the houses, right? :confused:

It’s weird that you can’t place a workshop, the only things needed are: the crafter (without bugs. If he/she can’t get to the resources and to the place where the workshop is going to be placed, it will never be placed), and the necessary resources harvested (carpenter: wood, mason: stone, weaver: fiber and wood).

I have something to add about the ghost workshop:

I have a save where a building where I can place furniture and workshop ghosts, but neither are ever placed by a citizen. Also, while it allows me to place a stockpile, the stockpile is never used.

I have not been able to find anything physically wrong with the building. Perhaps the citizens are convinced it is haunted and simply refuse to use it…


I can confirm the all function stop, it seems like they do it to me when I save a quit then restart the game
they did this around where the fire used to be then I undeployed it to see if it worked.

This happens somewhat often, but usually fixes itself. Usually, I need to save my world multiple times and reload them because they simply sit around and do nothing. Basically, at random points, one or more of my people, any job, will stop everything and stand around, moving a little every now and then. They don’t eat when they are hungry and they won’t go to beds when they are tired.

(tried to put a picture, but it said new users can’t upload pictures, so sorry i can’t explain better)

3 questions,

1: does this happen when you reload a game, not from exiting. just reloading.

2: does this happen when the game goes too long (ie: more then 16 days of game time)

3: does this happen if you have multi builds going on.

its an AI bug. i think the thread is somewhere here in the forums.