Custom Building Creation Error/Premade Editing Error

Summary: When attempting to build a custom building and edit it while under contruction a error pops up, And my settlers won’t build any building after or allow me to place new buildings to be made, premade or custom forcing me to start over.
Steps to reproduce:

  1. Making a Custom Building and trying to edit it during contruction.
  2. Editing a premade building during contruction (for me i tried to add a carpenter sign to building)

Expected Results: Editing and making buildings with no issue.

Actual Results: issue forcing a restart.

Notes: Nothing else seemed to duplicate this only when trying to edit buildings under construction.

Attachments: develop-2972 (x64)
…h/components/entity_forms/entity_forms_component.lua:359: assertion failed!
stack traceback:
[C]: ?
[C]: in function ‘assert’
…h/components/entity_forms/entity_forms_component.lua:359: in function ‘place_item_on_structure’
…/fixture_fabricator/fixture_fabricator_component.lua:266: in function ‘_place_item_on_structure’
…/fixture_fabricator/fixture_fabricator_component.lua:243: in function ‘_place_fixture’
…/fixture_fabricator/fixture_fabricator_component.lua:203: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:41: in function <…/fixture_fabricator/fixture_fabricator_component.lua:39>

Version Number and Mods in use: no mods used current version 0.15.0 (develop 2972) x64

System Information: Windows 10 64 bit Processor Intel® Core™ i7-3770K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 8 Logical Processor(s) Installed Physical Memory (RAM) 24.0 GB
Total Physical Memory 24.0 GB
Available Physical Memory 16.1 GB
Total Virtual Memory 48.0 GB
Available Virtual Memory 37.8 GB

Welcome to the forum, @Uldakh :slight_smile:

Could you check if this is reproducible on the latest version?

I believe some of the devs mentioning that they fixed it so now you can’t edit a building while it is being constructed or something like that (editing while building is being constructed has never been implemented, we’ll see if they get to it in the future).

doesnt seem like its giving that issue anymore but i did notice that it wouldnt place a door on a building for some reason idk what caused it but the door was in storage waiting to be placed and all that was left was a hole in the building.

Yeah, hearthlings not wanting to place things that are stored in containers has been reported many times.
And I think there were issues with doors recently too. Devs are going to work on improving and fixing building bugs for A17.

You can try saving and reloading, or getting the door to a stockpile if it was in a container (make sure it’s the correct type of door too) to see if they respond and try to place it :sweat:

For the moment I’ll tag this as resolved.