Can't finish editing

I created a custom building and when I try to press on “Finished Editing”, then my hearthling won’t start to build. When I click on the building again, it tells me I still have to press “Finished Editing”. When reloading the game, an error message appears. See:

release-566 (x64)
…onehearth/components/building/building_component.lua:386: attempt to index local ‘entity’ (a nil value)
stack traceback:
radiant/modules/common.lua:237: in function ‘report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
…onehearth/components/building/building_component.lua:386: in function ‘_trace_entity’
…onehearth/components/building/building_component.lua:145: in function ‘_restore_structure_traces’
…onehearth/components/building/building_component.lua:94: in function ‘obj’
radiant/modules/events.lua:75: in function ‘instance’
radiant/modules/events.lua:227: in function <radiant/modules/events.lua:221>
[C]: in function ‘xpcall’
radiant/modules/common.lua:257: in function ‘xpcall’
radiant/modules/events.lua:221: in function <radiant/modules/events.lua:187>

Steps to reproduce:

  1. Haven’t tried to reproduce the bug on a different building, but reloading didn’t help

Expected Results:
When I press “Finished Editing” it should trigger my hearthlings to start building

Actual Results:
I click on “Finished Editing” and it doesn’t trigger my hearthlings to start building. Instead, I can click on “Finished Editing” over and over again, without anything happen.

Savefile: SH_Save_FinishedEditingError.7z (3.8 MB)

Version Number and Mods in use:
Alpha 17, Release 556

Tried to reproduce the bug. Same seed and mostly the same place of the building. As soon as I try to place the roof, the error message appears. This time though, it let me click the “Finished Editing” button, BUT it completely removed the walls! My hearthlings tried to build the foundation, stairs and the roof, but the walls just disappeared.

i thought it was a two button press to get them to build. “finish editing” just allows a chance for last decision to get rid of the building before pressing “build” button. So “finish editing” and then “build” would be the two button presses.

Although the error is concerning though… wonder why that happened…

Like I said, in my try to reproduce it, I could press finish editing and start the whole building process. But it completely removed the wall from my designed building.

1 Like

Thank you for reporting this! I’m looking at the save now. Those walls are definitely disappearing …

1 Like

I think it has something to do with my flooring. As you can see in my savefile, I used those red squares on the foundation and the floor of the second level. Now I tried to build as good as possible the same building (same seed, same place) and didn’t use the floor pattern:

As you can see, now the game let me press on “finish editing” and it didn’t remove the walls.


But funnily enough, the start to place scaffoldings in the strangest places: