Crashes on expedition roster, "assertion failure"


#1

Summary:
I open up the game, wanting to play the new Stonehearth updates and when i finish picking the difficulty it brings me to the expedition roster. The thing doesnt load and provides me with an error shown here Gyazo - 02bb0ec5ad652b90ac4ff4eda98fd5e6.png. I’ve tried uninstalling, fixing the cache thing, doing different story/difficulties and everything and its not working.

Steps to reproduce:

  1. Open game
  2. Press new game
  3. Choose your story and difficulty
  4. “Expedition Roster” GUI frame comes up and your presented with the error, linked above.
  5. rip ;(

Expected Results:
Allowed to pick my starting weapons/equipment with the money and then get into a fun game.
Actual Results:
Crash
Notes:
fix pls thanks mates
Attachments:


Version Number and Mods in use:
Latest version, no mods m8
System Information:
old 2010 expensive laptop, Windows 7, 64 bit, 6 GB ram, i5 2.30 GHz


#2

Hello, @Tigranese, welcome to the forum :slight_smile:
So the error you’re getting is this:

Which graphic card do you have? Are your drivers up to date (check in the manufacturer’s website)?

The Stonehearth version you’re trying to play is the Alpha 16 r2940, right? So this means that before, you could play Stonehearth without problems? Which Graphic settings do you have in game?


#3

Somonene said in old post it could be StoneHearth need Windows 7 Service Pack 1.
But Relyss is right to put the last graphic card video drivers (like this infamous Intel Graphic Card ^^).
You must put all graphics settings to low like this :

  • Shadow Detail : Off
  • Maximum Number of Lights : 1
  • Maximum Number of Shadows : 0
  • Draw Distance : 500
  • Enable High Quality Graphics : Disable