Crash To Desktop on late game with ACE


#1

Summary:

Crash to desktop after getting to day 4 of hearthmun Winter (game was started on spring)

Stonehearth.log:
stonehearth.log (67.6 KB)

Attachments:

crash.dmp (264.8 KB)

1546208471105.rar (9.4 MB)

Versions and Mods:

Latest Version with ACE 0.9.2 Hotfix 3, and Dark Spirit template.

System Information:

Windows 7 Pro, Radeon HD7950 Adrenalin driver 18.12.3 , external monitor ASUS VE278

Have you attempted basic troubleshooting steps here: Crashing on start? Read this! UPDATED October 18, 2016

Not a crash on startup but check OK.

Notes:
Crash first appear with the first version of ACE and so on.
It seem to happened after the same amount of game time, even if i take an old save and keep playing until i reach it, i get the CTD.

From the log file only the end seem relevant.
sysinfo | Memory Stats: Fatal Exception
sysinfo | Total System Memory: 15.939 GB (17114390528 bytes)
sysinfo | Current Memory Usage: 2.521 GB (2707275776 bytes)
sysinfo | Total Address Space: 8.000 TB (8796092891136 bytes)
sysinfo | Available Address Space: 7.997 TB (8792616792064 bytes)
sysinfo | Used Address Space: 3.237 GB (3476099072 bytes)


Crash to Desktop in late-game with ACE & main game fully updated
Crash to Desktop in late-game with ACE & main game fully updated
#2

The xpcall is usually mod related and can sometimes be fixed by just closing and opening. The others were remnants of an older version of ACE installed. The Archipelago mod has also been updated to prevent some of these errors. I will test out the save to see what’s up


#3

Thanks Nikia,
Hope you can find something relevant.


#4

All fixed. The issues were caused by an outdated version of ace (Please update from the workshop by subscribing to it), you were out of inventory space ( I sold a few things to give you room ), and an ogre group spawn off map. Everything is fixed, you just need to update ACE. When you load this file, choose the GREEN button that says “Apply Mods”.

http://s000.tinyupload.com/?file_id=00462679774852077393


#5

I have just tried the save and apply the mod change, but i’m getting the same result.
This is the new log and updated save.
I was trying to add some stone chest near my storage building and it CTD just after i add 2 of them.

stonehearth.log (30.7 KB)
1546552000360.rar (9.0 MB)


#6

Are you on the official version of Stonehearth or are you on the [latest] (beta) version?


#7

I’m on the steam latest beta branch.


#8

Ok, in your Stonehearth file, can you please delete user_setting.json and launch stonehearth? It will create a new file. After that, can you please launch your save. You will need to pause the game the second you load in, teleport any idle hearthling you see in the town citizens window (by going to their character info window, and clicking the teleport icon in the upper right). After that, make sure you split your patrolling parties (knights/clerics/footmen/bowmen) into 2 groups (you can click the group flag color and then click the button with the 3 faces on it to add or remove hearthlings from each).

The save I sent you was run for a full day/night cycle and only this latest one, you’ve just uploaded, am I experiencing crashing with. I am crashing the moment the hearthlings start looking for food and a few are out of range.


#9

Even after fixing, this error is happening (so I would redownload the upload I sent you, not the latest one you just uploaded):

2019-01-03 17:50:35.124167 | server | 0 | simulation.core | took 954 ms to update game state
2019-01-03 17:50:35.124167 | server | 1 | simulation.core | game loop exhausted before any jobs processed!
2019-01-03 17:52:44.805006 | server | 0 | simulation.core | took 120 ms to update game state
2019-01-03 17:52:44.806006 | server | 1 | simulation.core | game loop exhausted before any jobs processed!
2019-01-03 17:52:49.305004 | client | 1 | horde.general | over_lifetime_[rgb] properties are no longer supported. Use a single over_lifetime property.


#10

I’ll try deleting the user_settings.json

Do you think it’s because i’m too low on food and hearthling are too far from it to be able to eat ?


#11

There are also a few stuck hearthlings too, that are just standing in place. There should be 4 that you have to teleport to the surface or to an open space. Your food storage is too far from where they sit and eat at. The one hearthling (511238 Eyla Oppen) is attempting to get food and sit down, but her way to get to the seating is too far (when I tp her closer, I can atleast get her to finish eating before the game crashes)


#12

Thanks for the help @Nikia, but this save is unrecoverable.
It keep crashing at approximatly the same moment in game.
I’ve move to another Save without ACE for the moment.


#13

Summary:

Late game consistently crashing to desktop for unknown reasons with ACE enabled.

Stonehearth.log:

stonehearth.log (6.1 MB)

Attachments:

Didn’t find a crash dump

Versions and Mods:

ACE mod, both mod & main game versions managed by steam

System Information:

Windows 10, external monitor, GTX 1070

Have you attempted basic troubleshooting steps here: https://discourse.stonehearth.net/t/crashing-on-start-read-this-updated-october-18-2016/13297

Not crashing on start

Notes:

[Any additional useful information]


#14

You should be able to upload files now.


#15

I encountered late game crashes with no dumps when trying to save my game. If this is the case, I have found 90% of the time an item is bugged, and selling it triggers a crash upon saving. I rapid fire save & load emptying my inventory of non-essentials until landing on the item that causes the crashes. With a bit of repetition you can manage to sell or delete the item and save, giving you a checkpoint of sorts to continue past the bug. From there you shouldn’t encounter any more problems.

This is all assuming you had the same type of crashes, but perhaps troubleshooting your inventory is necessary.


#16

This isn’t occurring during a save @Omni


#17

With some experimentation however, it might be a gearbox getting picked up / moved that’s breaking things. Will keep playing for a bit but I destroyed the block instead & it hasn’t crashed yet.


#18

NVM, crashed regardless, that’s not it


#19

Yeah, no idea, curious if the logs tell us anything


#20

Seems like an animation issue got you in a really bad loop before you crash; could you provide the save file? Would help a lot :smiley: