[Con] Wall Loop Bug (Walls move; disappear; game crashes)

Title: Walls move when placed; crash game

Summary: When creating a wall loop with connected walls, the walls move from placed location and overlap items that are adjacent (if any). Once wall is drawn, system hangs then crashes.

Steps to reproduce:
Open game.
Create stockpile/deal with early game activities.
Select Wall Loop and hold shift key for connected walls.
Complete Wall loop selection.

Expected Results: I should have a series of walls ‘ghosted’ in the selected location to be built by my citizens.

Actual Results: Each wall segment shifts from selected position one ‘block’ diagonally (in the direction of the sun-set??). Once walls have been drawn, wall locations disappear; game freezes for 6-12 seconds; game closes completely.

Versions and Mods: Current Alpha. No mods.

System Information: Windows 8.1; AMD FX-6200 Six-core processor running 3.8 GHz; 16 GB memory; AMD Radeon HD 7570 video

BUG: Building wall loops crash game inconsistently.

When building wall loops in the game, whether using shift to extend or doing one section, in a straight line or around corners, the game may crash.

Steps to reproduce:
I was unable to find a consistent set of circumstances in which to cause the game to crash. I did find that I was unable to get the game to crash while building walls of any length and shape while the F1 overlay was selected. I ran tests across increasing chunk lengths and increasing number of corners, and the game would crash each time, but none of them were in response to a consistent build type.

Expected Results:
I expected the game to crash upon building an extended wall across chunk boundaries, whether 1, 2, or more - but under the same circumstances each time.

Actual Results:
I was able to consistently recreate the crash, but unable to consistently recreate the trigger.



Versions and Mods:

System Information:
Processor: AMD E1-1500 APU with Radeon HD graphics 1.48 GHz
RAM: 4 GB (3.71 usable)
Sytem: 64-bit operating system, x64-based processor
Edition: Windows 8.1

1 Like

thanks for the report… @rbowman1234, i’ve merged your similar report here…

although, i think this has already been reported elsewhere, yes? its getting harder to keep track of where we’ve seen reports… :wink:

We were posting this at the same time! There is another confirmed bug about building the simple structure across chunk boundaries crashes the game, but I didn’t see one about the wall loop. As an aside about the simple structure, if you build it across chunk boundaries with the F1 overlay activated, the game doesn’t crash (at least not consistently - I tried several times while testing the wall loop issue).

On a related note to these, trying to build the wall part of the way up a cliff face will cause the game to hang, then crash.

Sorry for necro, but I also have crash when tring to join two building with a wall section even if its not fully enclosed. Soon as the last wall post touches the second building the game freezes and I have to use task manager to close it

not a problem! if the bug remains, its good to bring it back to the surface… :+1:

So now… for the same setup if you start the wallpost from the building to join the wall it will work ok, but if you try to finish the wall joining to the building it will crash

Tried it 3 times

Edit: Added Pict, also forgot to mention all the crashing happens during the building design phrase without starting construction.

1 Like

I think I have another reproducible bug, that would fit this topic (otherwise feel free to detach it).

Building several layers of “floor-like material” (i.e. actual floors and slabs) with different layouts causes the wall loop tool to cause exceptions (LUA and native). The building tool seems to break after that, while the game itself continues running. Screenshots for illustration and reproduction:

Step 1: Build some kind of floor. In this case, it’s already a wooden slab.

Step 2: Build a second layer with different layout (e.g. smaller) on top of that. For technical reasons, this obviously must be a slab.

Step 3: Try to place a wall loop around this. This results in both the native exception message and the LUA errors shown below.

This of course makes it pretty hard to use walls (and therefore windows & doors) in my planned tree-house. So I’ll have to come up with a more manual approach ^^

Edit: completely forgot the stats: Windows 8, build dev-2283 on 32 bit. ^^