Combining two .qb files into one model

Basically, all I want to do is combine one QB file with another QB file, then save it as one. But MagickaVoxel doesn’t seem to support this. Is there anything free out there that does? Or will I have to buy something, say Qubicle? (Does Qubicle do it?)

Searching google for “how to combine two qb files” only returned people asking how to merge quickbook files :sweat_smile:

Use voxelshop. It support multiple matrix.

It is better than magica in everything basically. The only fault I see is that everything looks ugly in it.


Ok, I’ve combined my two models. In VoxelShop it’s showing up aligned perfectly, but when I open it in Magica the second thing I imported is offset by two. Any Ideas why? (6.9 KB)

The Shield and Helmet are part of the base.

What piece is wrong? And what settings did you used?
The equivalent to the Magica settings would be to export with all checkboxes unchecked, except the last one

The Armor is over to the right by two. What version of Voxel are you using? I don’t have those last three options on my export.

Mine is 1.8.02. As far as I know it auto updates.
Oh, and is correct here for me, in both softwares and after merged too.

Not back in V 1.5 it didn’t :slight_smile: Updating now.

Ok… something… screwy… happened…

Now, instead of the armor simply being off by two blocks only in Magica, somehow, now appearing in both Voxel and Magica, is the Base, with the iconic steel mail sitting in it’s foot.

Just… what? I re-exported the model with the settings above.

But did you merged all layers into one? Magica will not ready it correctly if there are two or more. At the bottom right of voxelshop below the layers there is the options to merge everything into one.

1 Like

It wouldn’t give me the option to merge them before, I tried, figuring it might throw it off. Now it does, which is great! /s

Weird thing is, all of the layers from the armor itself are still present. But the Voxels that exist are from the Iconic Version.

Eh. I’ve gone back and re-did it. Now it’s all aligned in both programs. Thanks for your help.