Chests of Gold Coins not counted in my Net Worth during Daily Update

Summary: My net worth of my town doesn’t include the Chests of Gold Coins. When I logged on today my net worth was at 7282 gold, but I still had 26 chests of gold coins in my stockpiles worth 25,740. When I opened up a merchant stall trade menu it displayed 25,740 gold at the bottom and as I sold stuff the value went up. But, my net worth went down as I had less stuff in my inventory. I opened up an earlier save game and it had the same problem. I’m running the alpha 18 latest and I downloaded the latest update from last night. This morning I tried to install the Better Market Stalls mod but it did not work (I probably did that incorrectly). I deleted the mod and still had the same problem. I also loaded up an earlier save after I deleted the mod and my gold was still not accounted for in the net worth. So I’m not sure if it was just a bug from the update or from the mod.

I stated a new game real quick and didn’t use any of my starting money to buy tools. I had a net worth of 175 so the new game is unaffected by this bug.

Steps to reproduce:

  1. Load up saved game.

Expected Results: Should have a net value of 30k

Actual Results: Net value of 7k. Chest of Gold Coins not contributing to my

Notes: Tried installing Better Market Stalls mod: [MOD]Better Market Stalls v0.11 (Updated 23Aug2016)


Version Number and Mods in use: Alpha 18 latest

System Information:


Could you upload your save so we can take a closer look?

OK, so here is an update. I was wrong about the problem going away when I started a new game. The new game’s new net worth failed to include my gold chests, as well. I uninstalled then reinstalled the game and everything worked fine. My net worth was 31k where it should be. So maybe just a small glitch. Do you still want me to upload the save? I can’t duplicate the problem anymore.

Hm, the issue probably isn’t related to the save then. I’ll see if there’s any issues when the mod is installed. Let me know if it happens again!

I apologize, when I reinstalled Stonehearth I didn’t select the latest branch. I went back and selected it and my load still didn’t have the gold chests count as the net worth. I’m uploading my save now and hope it helps. I am sorry about my erroneous post. I have the following mods installed: Columns, Settlement Decorations, and Tuhalu. I had the Better Market Stalls installed before but it was removed. (9.3 MB)

1 Like

So, not to beat a dead horse but I’m still having a problem even after deleting everything and starting over. I deleted all local content through Steam then deleted the Stonehearth folder in the Steamapps folder. So no mods and no saved games. I then downloaded Stonehearth through Steam and selected latest to get Alpha 18. I started a new town called Kickassistan and my gold from gold chests still isn’t showing up in Net Worth in Town Overview or Daily Update. Right now it says I have a Net Worth of 811, but I have 1180 gold sitting in my stockpile.

Also, I noticed that if I go into my stockpile under wealth and hover over the gold chest the tool tip says: It’s [str(self.stonehearth:stacks:stacks)] coins!

I have uploaded this save game as well if you want to look at a clean illustration. Thank you looking into this and if there is anything else you need me to do just ask. (4.2 MB)

Can you please try to do a clean install of the game? (delete the entire folder (but you can save out the saved_games and saved_objects folders) and then do a reinstall from steam. I think that “str(stacks” string you’re seeing is an indication that the game on your machine did not update properly and might have become corrupt some how.

As an example, here’s what I get when I load up your game (these numbers appear to be more correct?):

Thanks for uploading the save.
Let me know if that fixes it for you


OK, so I deleted the whole folder again along with all the saved games. I deleted local content and reinstalled Stonehearth. I installed the Alpha 18 latest and started a new game. The Net Worth seems to be working correctly as my gold is included in the total. But, the weird message I receive when hovering over the gold while looking through the contents of a stockpile is still there. See attached screenshot. I will continue to play with this build to see if the Net Worth issue comes back. Thank you for all your help and I apologize for making you work on this problem on a Friday night.

Stated a new game of Alpha 18 latest and about 5 days in I notice that my Net Worth still isn’t taking including my gold. Here is a screen shot that shows I have enough gold to get another Hearthling but the game doesn’t recognize that. I uploaded the save in case you wanted to look at it. (3.5 MB)

Thank you for fixing the bug. It works now!