Can a recipe have no imput?

simple question, hopefully with a simple answer:

can i make a recipe with imput
“” (as in nothing)

(why would you want this wouter? so things like wells could be crafting stations and i dont have to cheat and say empty bucket = imput, water and empty bucket output)

I have not worked with modding for a good 7-8 months now; but, I can’t think of anything that would unable you from doing this. I’d say go ahead and try it :slight_smile:

The worst thing that could happen is that you would get an exception thrown your way, and thus an output on your screen saying something like “Ingredient not found”.

My way to test it would be either leaving ‘ingredients’ empty

 "ingredients": [
 "produces": [
       "item": "mod-name:item-name"

or not even include the ‘ingredients’-section in my recipe at all :slight_smile:

true, but currently at work and so couldnt test it myself atm :stuck_out_tongue: was hoping someone else would have tried it before now ^^

Just copy the shepherd way of harvesting things automatically.
Make the well a renewable resource that renews it self from time to time, like sheep, and make the required job look for that, and order him to harvest it when ready.

Could do, but that beats the point unfortunately.

That way either you have to manually start/stop harvesting, or, if it just keeps going, get too much stuff.

But if doing it as a crafting recipe you can tell a crafter to maintain x amount, which would be ideal


Ah, I see!

Did a quick test and can confirm that my previous suggestion works; keeping “ingredients” empty will make it possible to craft your item without requiring any ingredients :slight_smile: (and no errors either, woohoo!)


nice! now i know what ill be experimenting with :slight_smile: thanks @Hamnisu!

1 Like

Any time @Wouter_Sikkema!
Stay safe and best of luck with your modding

1 Like

That is nice to know, in the past it was not possible, so I didn’t even tried.


I remember that! When I asked this a more than a year ago (wow), having no items threw an error, and specifiying zero of an item wouldn’t let it craft.

If it works now, that’s kind of a huge deal for me.

1 Like

its why i asked, because i remembered that too but i -thought- i read or heared somewhere that that got fixed up so it would allow it :stuck_out_tongue: glad its now possible!

1 Like

I think I missed your previous post - but hey it’s cool how it works now :smiley:
Do you know what prevented it in the past? Based on my limited (and these days “dusty”) modding-knowledge, I couldn’t think of something that would make it impossibe.