Building menu says I don't have materials which I do have

not_a_bug

#1

Summary: I have materials for a building but the building menu shows that I don’t thus the building is never finished.

Steps to reproduce:

  1. Build a sufficiently complicated building, like one with curtains over windows I guess.

Expected Results: Everything gets build.

Actual Results: It doesn’t. It says I’m missing materials that I have.

Attachments: https://image.ibb.co/mui6tp/samestuffagain.jpg

Version Number and Mods in use: Latest version? I don’t know. I can’t find the place where it says the version. I was running better_storage and better_stockpiles but I tried without them as well.


#2

That’s so strange :thinking: Could you upload that savefile please?

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Edit: actually, the windows in your placement menu have a cross in the middle, and the one in the cost list doesn’t. Are you sure it’s the same window type?


#3

You’re right I’m stupid. Delete this thread. And my shame.