BugReport-Will not continue building after reloading game

When I reloaded my saved game the workers were no-longer registering a place building which was half completed. Yet when I placed a new building they responded as usual, meaning it was not a issue of lack of resources. But a bug within the game.However I don’t believe this always occurs, yet it stopped the progress of the 3 buildings I was creating.

Thank you for reading and please fix this issue! :smile:

(Sorry if someone else posted this already).

1 Like

You should look and see if there is a space where they cannot reach holding up construction

Welcome to the forum, @cookielump :merry:

If you upload the savefile maybe we can take a look. It is likely that the building was stuck before that savefile, so not related to loading. To upload a savefile:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

I am having the same issue, but with a custom building. My workers just stopped building it after a certain point.

Potentially (?) related backstory: I had previously run out of stone, which stopped construction, so I told my workers to mine more, and then they were building and mining concurrently, which worked fine. Then, they all stopped and I finally figured out that it was because I was out of resource storage space, so I added a new stockpile zone and the stone collection resumed. However, I have not seen anyone work on the building since I place that new stockpile zone to get things moving again. They finished collecting the stone, and now are wandering around idly chatting with each other.

If you can provide a save file somebody can look it over and help you out. Usually when work stops its because theres a bit of scaffolding or a spot the hearthlings cant reach for some reason.

I tried building a ladder in one place but that didn’t seem to help. Here’s my save file:

ppl stopped building.zip (9.0 MB)

Thanks for your help!

Sorry for the late reply. After looking at the savefile, they couldn’t continue building because they can’t reach the bottom of the lake to build the ladders. Making a ladder to the bottom of the lake will make them resume building.