Alpha building errors

Running the Alpha client and building is stopping multiple times for no reasons
Steps to reproduce:
I have everything crafted and ready, I start my build, and after a little bit all the workers will leave the construction area and go idle.

Have tried multiple buildings and different locations once the building process bugs out and still doesn’t get finished.

Doesn’t happen on every new building, but when it starts, it’s hard to complete anything afterwards.

Version Number and Mods in use:
Alpha 20

System Information:

Could you upload a savefile where your hearthlings are idle instead of building, @Brommando15 ?

I actually deleted the file where all my buildings weren’t being built, but when it happens again I can. What it the process for uploading the save file for you?

To upload a savefile:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it here directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.
1 Like

Ok, when this happens again I will forward the file, thank you!

1 Like

vastion building (7.0 MB)

Tier 2 building bugged, workers are idle again with the structure still in construction.

I’m seeing something similar. Just unlocked Tier 2 buildings. Built Blacksmith’s house, it finished, but mid-scaffolding teardown my hearthlings stop removing it and start idling. Restart or reload & refresh build have the same result. All other pre-Tier2 buildings have had no issue.

Saves here: Stonehearth - Google Drive

Usually it happens when they remove lower scaffolding but miss something on top. Top has more priority when tearing down, but they can’t get there. Try looking closely at your building. Manually added ladders may help.
If that’s the case, this is still a bug/unoptimised pathing, so savegame would be useful for debugging.

1 Like

@deltafive5 which version were you playing, A19 or A20?

(This is release 693 Alpha 20).

Ok, so. Coffee in hand this morning, i tried two other Tier 2 buildings - corner townhouse and cozy townhouse. Presto no issue. I thought, well ok, maybe its because they are simple 2-floor buildings.

I tore down the old Blacksmith building, and it left some manual ladders (i placed) and 1 hearthling-placed ladder in the air. Thinking this must have been my bug, i build a ladder up to it and my hearthling was able to reach and remove. This is good.

So i decided to try the Blacksmith again; slightly moved over, keeping the speed ONLY on normal speed. I watched intently on the single-story roof area where it looked like they built a scaffolding and ladder under the roof area, which would leave me to believe in a top-down construction teardown they wouldnt be able to reach.

BOOM it worked. Everything was built correctly and no scaffoldings were left. They even were able to place lights in the corners, which I hadnt gotten to in my previous build.

Edit: uploaded the successful save in my Google Drive. See my link above.

I’m seeing this problem with both hearthling tribe and on normal and hard difficult, I might run a sandbox mode with only custom made buildings to see if the bug will happen again, I’m sure my other 3 files have the bug as well if you would like for me to upload them as well @Relyss
If you want me to, just want to do what i can to help

On the Vastion savefile, it’s stuck because there’s an unreachable ladder at the hill. If you make a ladder there, hearthlings will be able to remove it and continue tearing down the scaffolding.

Chris is still working on refining the reachability service, which should address most of these problems.
However there might still be some other bugs not related to reachability.

1 Like

Ok, thank you, I will look into it and keep you guys posted.

my issue is they won’t place down items like the wall lanterns, windows, or beds in a building. They will leave scaffolding everywhere. Even if I place ladders it does not help me.

1 Like

same with my files as well