Bugs with bridgebuilding & roadbuilding

Hey there i have new bugs for you guys,

Bug 1:

I had a Bug where the Scaffoldings were bugged into my bridge:

with buildmode

without buildmode

After it was finished the same bug came again.

You clearly see the Scaffolding here.

After this i tried to reproduce the bug and i coulnt do it.
Here a Screenshot how i wanted to reproduce it:

And what happened was nothing it was normally build, only the scaffolding was debuild later than ever, cause here might just be that the Pathfinder needed some time.

Later on it was debuild by my hearthlings.

Lets get to Bug 2:

Here i wanted to build an other style of road and wanted to debuild the old one:

This error came out as i tried to let it be removed with the buildingmode “delete” button

As i choose it with my mouse and wanted to build it, this came out:

It keeped getting more and more error-reports.

I dont know how or why the thing with the road happened, but it might have to do something that the first bridge was connected to the road and not build separately.
Thats all i have for now.



1 Like

Can confirm this in Alpha 13 too

Scaffold seems to be persistent after construction. (does not get de-constructed)

It seems that they are able to build straight flat bridges just fine, if you are however ordering them to build 2 story or multiple voxel high bridges then they seem to treat the bridge as a scaffold-able structure, they then decided after construction that scaffold was not needed so it didn’t exist. Here are some snaps of what I discovered.


See how they still construct the scaffold for the raised notches similar to the bridge on my original comment.


They ended up de-constructing the scaffold on both bridges, but I have seen this happen before, not sure what prompted them to do it, may have been because the second structure was so close to the first bridge that it initiated their “deconstruct phase” ?? xD

1 Like