Bug with cooking equipment

Well as the picture shows even when the equipment is placed, the recipe’s are not made
Steps to reproduce:

  1. get a cook
  2. place equipment
    3)order some food

Expected Results:
the food is made
Actual Results:
no food being made

its the latest version release 553. Complete fresh install and fresh debugtools install. restard is not the fix. Reordering the food fixes nothing either

That is indeed odd. I have not had that issue on the latest build. I run a lot of mods as well. Were there any errors reported in you stonehearth.log file?

1 Like

nope, only after about 2 hours of playing that the game crashes when i want to go to main menu :slight_smile: but no error pop-ups or anything

Weird. I just tried duplicating this and it worked for me. Those are items your cook built and not placed via the item stamper?

You have a cook right?

The only way I was somewhat able to replicate this was to use the item stamper after queuing everything. I don’t think the town inventory rechecks stuff from the stamper; only items created forces that check I think.

1 Like

no matter the reason or how it happens, it should not happen at all there for its a bugging my head of issue

It shouldn’t be a bug if you place an object into the world outside of what it’s expecting such as the stamping tool. It’s a mod, debug tools, that added a function, item stamp, that broke the game, not an in-game mechanic that failed. Assuming you did indeed use the stamp tool.

If you create the iconic version and have hearthlings place those, the game will register it better.

But hey, maybe one of the Radiant folks will have an idea for stamped items to update the town inventory on placement.

Hi there!
If restarting/reloading the save doesn’t fix it, please upload the save! One of us will take a look.

Hello @Doc_Brano, did this work correctly after reloading the save?

saving and reloading did not fix it, but when i restarted 2 days later it was gone and i had an extra set of cooking equipment in my inventory

Shall we consider this as not reproducible then?

If you can’t reproduce it again after restarting… :worried:

well at first it kept staying there even after a restart. Only closing the game completely and then restarting fixed it, so not sure how that is any different from restarting it ingame after saving it.

At least it is gone know, have not had issue’s with placing things before. This was the first time for me.

1 Like

Hmm… yes, I think what @yshan meant was either to restart the game (closing and reopening the application) or reloading the save.

1 Like

reloading did not fix anything that was clear to me. The complete restart (even closed my pc for the night) did. But don’t really understand the differents between the two seeing that reloading a save usally works with most small issue’s and error messages. But that is something for a different topic. :slight_smile: