Bug: 'Stonehearth has stopped working' on startup (Alpha 17)

Everytime I try to open stonhearth from the steam menu it opens and says stonehearth has stopped working with a windows message underneath.

Steps to reproduce:

  1. open stonehearth from steam

Expected Results: Stonehearth to open normally

Actual Results: Stonehearth Not responding with a popup Stonehearth has stopped working

Version Number and Mods in use: Alpha 18 (not sure if I need more detail)

System Information: i5, nividia 960 16 gb ram

could you provide the loginfos and if you use mods?

Yeah, I also can’t play Alpha 18 (steam latest version) while Alpha 17 works fine. The game with Alpha 18 doesn’t even start - no message no nothing.

I don t use mods and what do you mean by loginfos

in your stonehearthfolder you find a file stonehearth.log - in this are all infos and errormessages

Here is my error log

1 Like

thats all?

hmmm ok again when it tries to opengl - can you try to open it in windowmode - not fullscreen?

edit: just for info you can change this in the usersettings.json (enable_fullscreen = false )
edit2: second option try to start it without steam - so just go manually into the stonehearthfolder and start it there

this log says the game is running alpha 17. Were you trying to run A18 or A17? If A18, then it looks like a corrupt install …

1 Like

I already have gone into the stonehearth folder and opened it from their and whenever it opens it isin windowed mode.
Also I think it is in alpha 17 I just assumed it was in alpha 18 as it was the latest version.
edit: This might clarify the version because I am not sure which one it is the steam buildID says it is 1265365

1 Like

Figured out my problem it was a corupt install I used steam to validate some of the files and once it redownloaded them it worked. Thanks for the help. Also can i mark this thread as ‘Solved’.
edit: Just for clarification my game was alpha 17 and how can I get the steam version for alpha 18?


You need to enable “steam latest”. Right click on your Stonehearth under the “Library” tab on Steam app and choose properties. Then under the “Betas” tab, select “latest - Latest build. Minimally tested.”.

Let us know if you have further problems concerning loading the “latest build”. I did have a problem but now it’s been solved!


Thank you for letting me know