Bug Report: Items in stockpile not tangible


#1

Hey all, was playing and ran into bug where items turn intangible in the stockpile. Certain blocks become unusable even though they were never used in the first place and they glow white/blue. First screen shows the white fence post that is unusable and when the carpenter crafts a fencepost afterwards he drops it in that spot making it unusable. Crafting a different item forces him to drop it in a different spot which lets you craft once more. This bug affects other stockpiles as well. The food and wood stockpiles in the second screen are affected with the same issue but it is a blue highlight instead of white. There are error messages on both screens upon load of the save. I tried restarting the game but the error still shows. Hope this helps :slight_smile:

Edit:

Hardware Specs Below

CPU: AMD 8350 Stock Clocks
Graphics Card: R9 290X DCUII Latest Stable Drivers 14.4
Ram: 12GB
OS: Windows 7 64 bit Latest Build
SSD Contains OS
HDD1 contains Stonehearth (shouldn’t make a difference but there it is)



#2

I too ran into this today, amongst other bugs. It may not make a difference but I just added the game through steam as opposed to the standalone installer. This particular problem never popped up until I ran the game from steam. It may be worth ensuring that the Steam installer and the Standalone installer put the right files in the right place and do not tamper with any of the code during the download/install. Just a thought.


#3

I’m also playing via Steam, so it’s possible but unlikely. Depends if Radiant uses different files for each.